View Issue Details

IDProjectCategoryView StatusLast Update
0007808mantisbtfeaturepublic2009-06-26 12:07
ReporterCreatixEA Assigned Tojreese  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.6 
Fixed in Version1.2.0a1 
Summary0007808: Strike a resolved bug in notes and links
Description

When linked a bug in notes and links, would it be possible to strike it (like in Bugzilla)

I mean strike using the <strike /> HTML tag.

Would it be possible to extend this feature to all the application ?

TagsNo tags attached.

Activities

ryandesign

ryandesign

2007-03-09 20:47

reporter   ~0014152

Issue is not platform-specific.

ryandesign

ryandesign

2007-03-09 20:47

reporter   ~0014153

If we wanted to do this, we would not want to use any HTML <strike /> tags; rather we would want to use CSS styles.

vboctor

vboctor

2007-03-09 22:03

manager   ~0014157

At the moment if you hover the mouse over the issue hyperlink you will get to know the status and the summary. This is achieved using the title attribute for the anchor (a) tag.

I wonder if people still find this not enough. We can potentially go with the following options:

  • Leave as is.
  • Strike if issue status >= $g_bug_resolved_status_threshold.
  • Strike if issue status >= a new configuration option ($g_bug_strike_status_threshold).

I would be interested to go opinions about this.

CreatixEA

CreatixEA

2007-03-12 06:44

reporter   ~0014169

Hello,

I think that it only must be linked with the actual system without any change: if the issue is considered as resolved, it should be striked.

I think it would be too complex to have a specific status to strike it. Maybe confused.

exk72

exk72

2007-03-12 16:16

reporter   ~0014174

I would leave it as is, based on the hover action.

ryandesign

ryandesign

2007-03-13 23:53

reporter   ~0014178

Victor, I think striking out the bug number of resolved bugs would be useful, even if we already show some info when we hover; striking would be easier to see, because you wouldn't need to hover over it to see it. I have wished for this in the past. And again, we wouldn't actually do <strike>123</strike>; we'd do <span class="resolved">123</span> and set .resolved {text-decoration: line-through;} in the stylesheet. Using "resolved" as the class name may not be the right thing but you get the idea.

I don't think we need a new configuration variable; I think your second suggestion (strike if issue status >= $g_bug_resolved_status_threshold) is good.

CreatixEA

CreatixEA

2007-03-14 00:55

reporter   ~0014179

Why complexify this simple feature ?

My idea:

  • Same level as resolved
  • A checkbox in configuration that active (or not) a second css: strike.css that redefine the .resolved class

Then the .resolved class is defined by the main css style sheet, and if the checkbox is checked, then a second style sheet "striking.css" complete the .resolved class.

More simple, isn't it ?

caldarola

caldarola

2007-07-16 12:15

reporter   ~0015045

General speaking strike tag can be useful when some field, e.g. description, is updated.

jreese

jreese

2008-06-02 10:01

reporter   ~0017992

Implemented in trunk SVN r5306.

Related Changesets

MantisBT: master d430bad1

2008-06-02 14:00:48

jreese

Details Diff
Implemented bug 0007808: Strike a resolved bug in notes and links

git-svn-id: http://mantisbt.svn.sourceforge.net/svnroot/mantisbt/trunk@5306 <a class="text" href="/?p=mantisbt.git;a=object;h=f5dc347c">f5dc347c</a>-c33d-0410-90a0-b07cc1902cb9
Affected Issues
0007808
mod - core/string_api.php Diff File
mod - css/default.css Diff File

Issue History

Date Modified Username Field Change
2007-03-09 00:12 CreatixEA New Issue
2007-03-09 20:47 ryandesign Note Added: 0014152
2007-03-09 20:47 ryandesign OS Debian Sarge Stable =>
2007-03-09 20:47 ryandesign OS Version 1.0.6 =>
2007-03-09 20:47 ryandesign Platform Linux =>
2007-03-09 20:47 ryandesign Note Added: 0014153
2007-03-09 22:03 vboctor Note Added: 0014157
2007-03-09 22:03 vboctor Status new => feedback
2007-03-12 06:44 CreatixEA Note Added: 0014169
2007-03-12 16:16 exk72 Note Added: 0014174
2007-03-13 23:53 ryandesign Note Added: 0014178
2007-03-14 00:55 CreatixEA Note Added: 0014179
2007-07-16 12:15 caldarola Note Added: 0015045
2008-06-02 10:01 jreese Note Added: 0017992
2008-06-02 10:01 jreese Status @0@ => resolved
2008-06-02 10:01 jreese Fixed in Version => 1.2.0
2008-06-02 10:01 jreese Resolution @0@ => fixed
2008-06-02 10:01 jreese Assigned To => jreese
2008-10-20 16:49 Changeset attached master fb1c9a3f =>
2008-11-11 08:33 jreese Changeset attached master d430bad1 =>
2008-11-11 08:46 jreese Changeset attached master d430bad1 =>
2009-06-26 12:07 vboctor Status resolved => closed