View Issue Details

IDProjectCategoryView StatusLast Update
0007956mantisbtbugtrackerpublic2019-01-11 02:59
ReporterstbAssigned Tocproensa 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0007956: Disable project selection for users with only one project
Description

Users who are only allowed to see one project should not have a project selector.

It is quite easy to disable the project bar like this:

function print_project_menu_bar() {
    $t_project_ids = current_user_get_accessible_projects();

    if(count($t_project_ids) > 1)
    {
             ....

I guess it can cause problems if the user cannot change between all and the specific project (different filters etc.) So I let the combo selector in for sure. But I think it could be useful to force those 1-project-users to be always within the specific project (deny access to "all projects").

TagsNo tags attached.

Relationships

related to 0020054 closedcproensa Cant modify configuration for All projects if only one project exists 
related to 0025133 closedcproensa Project selection is shown even if the user has no accesible projects 
related to 0025110 closedcproensa Token error when login with a newly created user 

Activities

grangeway

grangeway

2007-05-10 17:06

reporter   ~0014493

hmm, nice idea, although that patch you propose doesn't really seem to "do it" in 1.1

Paul

onad

onad

2007-05-11 06:00

reporter   ~0014502

If you assign the user to the project as the default project, is that not working for you?

vboctor

vboctor

2007-05-14 01:56

manager   ~0014517

I think it is a good idea. However, we need to come up with a patch that works with 1.1 and handles sub-projects.

cproensa

cproensa

2019-01-01 07:58

developer   ~0061127

This is old, and seems like it's implemented since 1.2

Issue History

Date Modified Username Field Change
2007-05-10 08:35 stb New Issue
2007-05-10 17:06 grangeway Note Added: 0014493
2007-05-11 06:00 onad Note Added: 0014502
2007-05-14 01:56 vboctor Note Added: 0014517
2007-05-14 01:56 vboctor Status new => acknowledged
2015-08-26 18:13 atrol Relationship added related to 0020054
2019-01-01 07:42 cproensa Relationship added related to 0025133
2019-01-01 07:43 cproensa Relationship added related to 0025110
2019-01-01 07:58 cproensa Assigned To => cproensa
2019-01-01 07:58 cproensa Status acknowledged => resolved
2019-01-01 07:58 cproensa Resolution open => fixed
2019-01-01 07:58 cproensa Note Added: 0061127
2019-01-11 02:59 atrol Status resolved => closed