View Issue Details

IDProjectCategoryView StatusLast Update
0008939mantisbtdocumentationpublic2019-12-13 18:06
Reporternetres Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionno change required 
Summary0008939: Lifecycle model for a report in Mantis
Description

Attached is a draft model for the life cycle of a report in Mantis. Since I created this document for our internal purposes obviously some steps are adapted to our processes and might need a rewrite to become more generic.

Original format of the document is Visio (Omnigraffle format is also available), possibly I can send this document in an editable format to people interested in modifying/improving the model.

TagsNo tags attached.

Activities

2008-03-04 04:33

 

netres

netres

2008-06-30 09:11

reporter   ~0018235

No comments on this for 4 months? Is the model so perfect it does not need any improvement? Or is it so wrong so the only reasonable next step is to scrap it and start over?

vboctor

vboctor

2008-07-01 01:33

manager   ~0018254

That looks like a good example of how a company can use the Mantis workflow. it would be useful if you include the editable visio file.

Thanks for your contribution.

grangeway

grangeway

2008-07-15 15:46

reporter   ~0018564

Netres,

Could you upload your visio file

THanks
Paul

2008-07-16 05:48

 

Life cycle of a bug.vsd (84,992 bytes)
BAMaustin

BAMaustin

2009-04-02 19:17

reporter   ~0021375

Netres,

Does your process allow Reporter to "Reopen an issue" for refining?
Manage : Manage Configuration : Workflow Thresholds

It seems like there should be an ackknowledged feedback option when issues are closed as not valid, not in scope or not reproducible. Otherwise, the Reporters who are less skilled in bug reporting lose the motivation to contribute.

I also like to include a step when an Issue is resolved asking whether the fix requires a revision to User or Developer documentation.

slestak

slestak

2009-05-20 16:53

reporter   ~0021865

Would anyone be interested in a graphviz version of this model? I have been looking for a reason to use it.

am-gtz

am-gtz

2010-01-13 08:27

reporter   ~0024137

slestak: Graphviz version would be cool :) We don't use visio ...

dregad

dregad

2019-12-03 10:31

developer   ~0063183

While interesting, the proposed flowchart is still specific to a given workflow, so it is only useful as an example since it won't be applicable in all cases (e.g. most instances do not allow assigning issues to reporters). As such, I don't think it belongs in the Mantis documentation.

Issue History

Date Modified Username Field Change
2008-03-04 04:33 netres New Issue
2008-03-04 04:33 netres File Added: Visio-Life cycle of a bug.pdf
2008-06-30 09:11 netres Note Added: 0018235
2008-07-01 01:33 vboctor Note Added: 0018254
2008-07-15 15:46 grangeway Note Added: 0018564
2008-07-15 15:46 grangeway Status new => feedback
2008-07-16 05:48 netres File Added: Life cycle of a bug.vsd
2009-04-02 19:17 BAMaustin Note Added: 0021375
2009-05-20 16:53 slestak Note Added: 0021865
2010-01-13 08:27 am-gtz Note Added: 0024137
2019-12-03 10:31 dregad Assigned To => dregad
2019-12-03 10:31 dregad Status feedback => resolved
2019-12-03 10:31 dregad Resolution open => no change required
2019-12-03 10:31 dregad Note Added: 0063183
2019-12-13 18:06 atrol Status resolved => closed