View Issue Details

IDProjectCategoryView StatusLast Update
0009558mantisbtfeaturepublic2008-08-22 04:32
Reporterrstens Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformFirefox 2.0.0.14OSWindows XP 
Product Version1.1.2 
Summary0009558: Url encoded urls in $g_manual_url fail to show properly
Description

When entering a url encoded url in $g_manual_url in the config file, you would expect the link for User Documentation to work according to what you specified.
However, this is not the case as Mantis somehow strips the % from the url and renders the url invalid.

This is what url encoding is: http://www.blooberry.com/indexdot/html/topics/urlencoding.htm

If you manually replace the encode values with the actual values thinking that this would work to then you are confronted with bug 0009370.

One workaround that seems to work is to take your (long, encoded) url and create a tinyurl ( http://tinyurl.com/ ) and put that in your config file.

Steps To Reproduce

See above

TagsNo tags attached.

Activities

giallu

giallu

2008-08-21 02:32

reporter   ~0019188

So, AFAICS we just need to port the fix for 0009370 to the stable branch?

rstens

rstens

2008-08-21 19:38

reporter   ~0019198

No there are 2 issues:

  1. The encoded url issue that breaks the link
  2. 0009370

They are separate but related, my issue pertains to 1.

giallu

giallu

2008-08-22 04:32

reporter   ~0019206

IMHO there should be no need to manually urlencode the link, as regular users could be completely unaware of what that means or imply.

However, I'd expect any string you use for $g_manual_url to be properly urlencoded before being shown on the menu.

Can you please show me an example of one not working?

Issue History

Date Modified Username Field Change
2008-08-20 19:10 rstens New Issue
2008-08-21 02:32 giallu Note Added: 0019188
2008-08-21 19:38 rstens Note Added: 0019198
2008-08-22 04:32 giallu Note Added: 0019206