View Issue Details

IDProjectCategoryView StatusLast Update
0011327mantisbtreportspublic2018-02-06 21:17
ReporterZamolxisAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0rc1 
Target Version2.11.0Fixed in Version2.11.0 
Summary0011327: "Developer By Resolution" is the only box in the Summary page not ordered (at least it doesn't seem to be any logic behind it)
Description

The "Developer By Resolution" box in the Summary page seems to have no logic of ordering developers. If there is a logic, it's not related to any of the relevant columns. For a while I suspected it's in the order of devs joining the project, but it's not even that: the last dev that joined appears somewhere in the middle of the list. Also Access Level doesn't seem to play a role in the order.<br />
<br />
I believe the devs should be order based on one (or more) of the following criteria:<br />

  • (number of bugs) fixed<br />
  • (number of bugs) open<br />
  • % Fixed<br />
  • by name (alphabetically)<br />
  • or else Chronologically, in the order of joining the project<br />
TagsNo tags attached.

Relationships

related to 0023863 closeddregad Summary: Reporter and Developer by Resolution miss a Total column 

Activities

Zamolxis

Zamolxis

2010-01-05 10:38

reporter   ~0024048

Last edited: 2010-01-05 10:57

View 3 revisions

Same thing for the Developer Stats box, which seems to be ordered based on the same criteria.

EDIT: Small correction to my report above - it seems there is a logic, namely the order the user accounts were created. This was misleading for me, because one of these users started as reporter, but was appointed as developer only months later. So I expected him to appear at the bottom of the list, while he appeared in the middle of it (as per date/time of his account creation).

I guess this logic can be kept for the Developer Stats box, but I believe it should still be changed for Developer By Resolution. If the name says "By Resolution", the hierarchy in that box should say something about the dev's efficiency or amount of workload assigned. So ordering by the number of fixed or open reports assigned to him/her would make more sense IMO.

dregad

dregad

2018-01-20 17:26

developer   ~0058576

Last edited: 2018-01-20 17:28

View 2 revisions

For a while I suspected it's in the order of devs joining the project

According to the SQL query in the source code, it's sorted by handler_id (user id), so it's not exactly the order of devs joining the project, but rather that of users registration, as you pointed out in 0011327:0024048.

Implementing a more complex sort as you suggest does not really make sense at this time, because I think this page is long overdue for a major overhaul.

For consistency with the Reporters by resolution report, I think this should be sorted by total number of issues (descending).

Related Changesets

MantisBT: master 26ae1f63

2018-01-20 17:29:10

dregad

Details Diff
Summary: sort "Dev by Resolution" by total bug count

This makes the report consistent with "Reporter by Resolution".

Fixes 0011327
Affected Issues
0011327
mod - core/summary_api.php Diff File

Issue History

Date Modified Username Field Change
2010-01-05 10:30 Zamolxis New Issue
2010-01-05 10:38 Zamolxis Note Added: 0024048
2010-01-05 10:52 Zamolxis Note Edited: 0024048 View Revisions
2010-01-05 10:57 Zamolxis Note Edited: 0024048 View Revisions
2018-01-20 17:26 dregad Assigned To => dregad
2018-01-20 17:26 dregad Status new => assigned
2018-01-20 17:26 dregad Note Added: 0058576
2018-01-20 17:26 dregad Category feature => reports
2018-01-20 17:28 dregad Note Edited: 0058576 View Revisions
2018-01-20 17:32 dregad Relationship added related to 0023863
2018-02-01 12:03 dregad Changeset attached => MantisBT master 26ae1f63
2018-02-01 12:03 dregad Status assigned => resolved
2018-02-01 12:03 dregad Resolution open => fixed
2018-02-01 12:03 dregad Fixed in Version => 2.11.0
2018-02-01 12:06 dregad Target Version => 2.11.0
2018-02-06 21:17 vboctor Status resolved => closed