View Issue Details

IDProjectCategoryView StatusLast Update
0011721mantisbtpreferencespublic2018-05-23 07:15
ReporterHein_Meijer Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status newResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0011721: preferred setting at what moment the bug number becomes strikethrough
Description

When a bug is reported "resolved" the bug number (text) becomes strikethrough (strikeout)
I want this strikethrough of the bug number only when the bug gets the status "closed".
Is there a possibility to make this a user preferred setting so I can choose that strikethrough in my case will be only the items that have status "closed".

TagsNo tags attached.

Relationships

has duplicate 0024475 closedatrol Resolved(or closed) issues have a css class .resolved, i would like to have line through only for tested and closed 
related to 0022492 closedcommunity Regression: Resolved/Closed issues are not shown with a line-through (strike-through) 

Activities

Hein_Meijer

Hein_Meijer

2010-03-29 08:52

reporter  

strikethrough bug number.bmp (960,066 bytes)
atrol

atrol

2010-09-03 16:46

developer   ~0026576

You can set
$g_bug_resolved_status_threshold = CLOSED;

Be aware that this affects also other functionality

david_s_nl

david_s_nl

2010-09-21 03:38

reporter   ~0026824

@atrol:

The suggestion was to create a setting to define at what status a bug number gets displayed with a strike-through.

Something like: $g_bug_receive_strikethrough_status = RESOLVED;

Plus adding the possibility to not use strikethrough at all.

Thank you for your suggestion, but unfortunately i don't think that's a useful alternative because like you say it affects (too much) other functionality.

atrol

atrol

2010-09-21 08:25

developer   ~0026827

First I thought about reopening this issue as a new feature request.
Now I am hesitating, because there is already an option to change behaviour of display.
Check http://docs.mantisbt.org/master/en/administration_guide.html#ADMIN.CUSTOMIZE.CUSTOMFUNCS

For example have a closer look at function custom_function_override_roadmap_print_issue

david_s_nl

david_s_nl

2010-09-21 11:34

reporter   ~0026829

Hello atrol,

1.
as far as i can see the custom functions can only modify the display of the bug number in the roadmap (and maybe changelog) page,
but not in bug descriptions, bugnotes, etc.

I just noticed the configuration option was suggested (but not implemented) by vboctor here: 0007808:0014157

2.
Another thing i'd like to mention: when you take a look at the Changelog page, you will see that reading a bug number is alot harder when its striked-through.
If a bug is listed on the changelog page, its status is ALWAYS >= $g_bug_resolved_status_threshold, so whats the use of striking it through... it doesn't give any extra information and makes reading the numbers more difficult.

This was not done to be "consistent" by the way, because in the View_all_bug page bugs with a status >= $g_bug_resolved_status_threshold are NOT striked-through either.

So, my preference would be: do not strike-through bug numbers in the changelog page.

atrol

atrol

2010-09-21 17:43

developer   ~0026831

What about just changing a.resolved in default.css to { text-decoration: underline; } ?

Result:
Display auf resolved issues in
"View Issues" is not striked
"Change Log" is not striked
"Roadmap" is striked, but if unwanted, can be changed with custom function.

TBH, I don't know why there is a difference of implementation in "Change Log" and "Roadmap" . This was before the time I started with MantisBT

I think this will all be changed when 0004227 and 0006628 will be realized.

david_s_nl

david_s_nl

2010-09-22 16:31

reporter   ~0026845

That result sounds OK to me. It would fix item 2 mentioned in my previous comment.

To fix item 1, a new configuration option ($g_bug_strike_status_threshold) would have to be added.

However this is just my point of view, its probably a good idea to ask opinions of some others :)

atrol

atrol

2010-09-23 03:03

developer   ~0026847

Did you try changing the css ?
Bug descriptions and bugnotes are also affected by it, so your item 1 should also be fixed with it

david_s_nl

david_s_nl

2010-09-24 17:33

reporter   ~0026856

Yes I have tested it, the result is: strike-through is no longer used anywhere (changelog, roadmap, bugnotes, bug descriptions, etc.)

It does not solve item 1 because we only want for example issues with a status of "closed" (not "resolved") to be striked-through, which could be accomplished by using a configuration setting ($g_bug_strike_status_threshold).

atrol

atrol

2010-09-26 16:27

developer   ~0026865

Seems that we are talking about differnt things

You wrote

  1. as far as i can see the custom functions can only modify the display of the bug number in the roadmap (and maybe changelog) page,
    but not in bug descriptions, bugnotes, etc.

I thought this was your item 1, and your problem was that you are not able to change the behaviour for descriptions and bugnotes
As you are able to change this by CSS I thought this is solved.

The feature request of Hein_Meijer is not solved.

david_s_nl

david_s_nl

2010-10-06 15:20

reporter   ~0026984

Hi Atrol,

well what Hein_Meijer wants is:
"strikethrough of the bug number only when the bug gets the status 'closed'"

This would be solved by Item1: adding a configuration setting $g_bug_strike_status_threshold.

$g_bug_strike_status_threshold = "CLOSED" would achieve this because the result would be striking through bugs with status "CLOSED", instead of what Mantis currently does: striking through bugs with status "RESOLVED".

Issue History

Date Modified Username Field Change
2010-03-29 08:52 Hein_Meijer New Issue
2010-03-29 08:52 Hein_Meijer File Added: strikethrough bug number.bmp
2010-09-03 16:46 atrol Note Added: 0026576
2010-09-03 16:46 atrol Status new => resolved
2010-09-03 16:46 atrol Resolution open => no change required
2010-09-03 16:46 atrol Assigned To => atrol
2010-09-21 03:38 david_s_nl Note Added: 0026824
2010-09-21 08:25 atrol Note Added: 0026827
2010-09-21 11:34 david_s_nl Note Added: 0026829
2010-09-21 17:43 atrol Assigned To atrol =>
2010-09-21 17:43 atrol Note Added: 0026831
2010-09-21 17:43 atrol Status resolved => feedback
2010-09-21 17:43 atrol Resolution no change required => reopened
2010-09-22 16:31 david_s_nl Note Added: 0026845
2010-09-23 03:03 atrol Note Added: 0026847
2010-09-23 03:03 atrol Status feedback => new
2010-09-24 17:33 david_s_nl Note Added: 0026856
2010-09-26 16:27 atrol Note Added: 0026865
2010-10-06 15:20 david_s_nl Note Added: 0026984
2017-04-02 07:02 atrol Relationship added related to 0022492
2018-05-23 07:15 atrol Relationship added has duplicate 0024475