View Issue Details

IDProjectCategoryView StatusLast Update
0012522mantisbtplug-inspublic2017-02-03 10:33
Reportercas Assigned Tocommunity  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionopen 
Product Version1.2.0 
Target VersionFixed in Version 
Summary0012522: Set duedate automatically
Description

This plugin allows for setting the duedate automatically to today + a configurable number of days.

TagsNo tags attached.

Relationships

has duplicate 0015591 closeddregad SLA Statistics - 
related to 0013794 closedatrol New plugin for: Submit with expired due date 
related to 0015239 closeddregad It is not correct - Due date in hours for priority 
related to 0010211 acknowledged SLA 
related to 0020711 closedcommunity Support default due date for submitted issues 

Activities

cas

cas

2010-11-09 06:12

reporter  

SetDuedate.zip (2,098 bytes)
atnz

atnz

2011-01-10 00:40

reporter   ~0027866

This might be able to be extended to support the note regarding automatically calculating the expected start and finish as per note I added in 0010586 ?

atnz

atnz

2011-01-10 00:48

reporter   ~0027867

http://www.mantisbt.org/bugs/view.php?id=10586

atnz

atnz

2011-01-23 14:36

reporter   ~0028036

Sponsorship would be in conjunction with the related item.

cas

cas

2011-03-02 02:30

reporter  

SetDuedate20.zip (3,299 bytes)
cas

cas

2011-03-02 02:31

reporter   ~0028337

Due date plugin updated to version 2.
Now Due date can be set based upon priority.
Thanks go to Istvan Baktai.

cas

cas

2011-03-03 02:58

reporter  

SetDuedate21.zip (3,672 bytes)
cas

cas

2011-03-03 02:58

reporter   ~0028355

Minor adjustment, now only using working days in the calculations (ie weekends are ignored)

cas

cas

2011-03-03 11:27

reporter  

SetDuedate211.zip (3,672 bytes)
cas

cas

2011-03-03 11:27

reporter   ~0028361

managed to miss out on a semi-colon, hence a new version (2.11).

cor3huis

cor3huis

2011-04-10 17:13

reporter   ~0028581

It would be good to submit code to http://git.mantisforge.org/. This will make your plugin more visible to other users.

cas

cas

2011-04-11 03:09

reporter   ~0028584

@Cor,
I should get into that but it just did not get any priority.
Besides i do not find it very userfriendly but that may be just my perception.

cor3huis

cor3huis

2011-04-11 11:00

reporter   ~0028588

The page is indeed not the niced, I agree, something as http://drupalmodules.com/ would be great for mantis, but this is a start....

and getin the plugin is as simple as
$ git clone http://theurlofourrepohere.git

Thanks for you great pluging BTW

cas

cas

2012-05-15 07:18

reporter   ~0031839

Current plugin is based upon priority only. Would it make sense to add option to set number of days by project/category?

cas

cas

2012-06-05 06:02

reporter  

SetDuedate30.zip (6,191 bytes)
cas

cas

2012-06-05 06:04

reporter   ~0032014

Version 3.0 has been released:
Added option to set duedays by Project/category.
Default the duedate is calculated based upon priority.
This can be overridden by defining a value for a given project/category

Current calculation is based upon days

cas

cas

2012-07-04 05:37

reporter  

SetDuedate310.zip (6,474 bytes)
cas

cas

2012-07-04 05:38

reporter   ~0032247

Released version 3.10
Duedays can be set by project/category/priority.

Be aware that there is nop tru upgrade process.

Forgotten

Forgotten

2012-08-29 09:05

reporter   ~0032698

I'm not really php programmer, but as i understood in file SetDuedate.php function:

 function init() {
            plugin_event_hook( 'EVENT_REPORT_BUG_DATA', 'setDate' );
            }
  • means that plugin initiates when issue reports. For me it would be useful to make it run even on bug edit, as i understood it would be 'EVENT_UPDATE_BUG' event. But when i tried to add it to the function, it does not worked.

Can You help with this.

Also if someone need to use hours instead of days, make changes in strings 48 and 51. Just change 86400 to 3600 (it is time in seconds).

cas

cas

2012-08-29 09:54

reporter   ~0032699

The intention was to set a duedate if it was not done manually.
If this should always kick in then duedate cannot be overwritten anymore.
is that your intention?
This can be made but would require a config parameter.

Forgotten

Forgotten

2012-08-29 10:21

reporter   ~0032700

Last edited: 2012-08-29 10:23

View 2 revisions

I need due_date to change automatically when priority of issue was changed. It looks like it can be done using Your plugin.

As i see, function init() responsible for events on which this plugin starts.Now it works only on bug report, and i want it to work on bug edit/update to make possible changing due_date automatically.

cas

cas

2012-08-30 04:22

reporter  

SetDuedate320.zip (6,928 bytes)
cas

cas

2012-08-30 04:23

reporter   ~0032704

Last edited: 2012-08-30 05:53

View 2 revisions

@forgotten:
Try out version 3.20, it should provide the needed functionality (after config).
I have not tested this, that is for you.

Forgotten

Forgotten

2012-08-30 08:39

reporter   ~0032727

Ok. I'll try, and i'll post results here!

Forgotten

Forgotten

2012-08-31 08:27

reporter   ~0032744

Thnx.

All i asked is working ok.
I saw function Change Date. It is pretty same as function setDate except of few checks.

But i have some problems with define Duedays by category/priority. I can't chose any category. And when i tried to add it manualy in database it does not made any effect.

Maybe it is problem with my configuration, but i decided that You would like to know about potential problem.

cas

cas

2012-08-31 08:58

reporter   ~0032747

The choice is per project/category so the system expects categories by project.
Suggest you verify yor config in elation to that.

Forgotten

Forgotten

2012-09-07 05:02

reporter   ~0032810

I have changed plugin a little for my needs. Now it sets due_date only for working hours (in my case from 11:00 till 20:00, from Monday till Friday). And made it to start counting of due_date from 11:00 if issue were send at night, or from 11:00 Monday, of issue were send at weekend.

If You want, i cand send You my version.

cas

cas

2012-09-07 07:32

reporter   ~0032812

@forgotten,
If you made those changes configurable then yes, attach it to this issue.

Forgotten

Forgotten

2012-09-07 08:28

reporter  

SetDuedate330.zip (25,843 bytes)
llaumgui

llaumgui

2012-09-28 10:35

reporter   ~0032984

Hi,

Is it possible to allow freeze ? Explain : I can chose somes status which freeze the due date.

cas

cas

2012-09-29 03:35

reporter   ~0032989

You mean tat if an issue has a certain status that the due date cannot be changed (automatic or manual)?
This is not possible in the current setup.

Rikard03

Rikard03

2012-11-23 05:07

reporter   ~0034363

Last edited: 2012-11-23 05:08

View 2 revisions

Hi Cas

I installed the SetDueDate Plugin, but i do not undestand the functionality.

For Example:

For an issues open with Urgent Priority and assigned to developper (Due Date in hours for priority : Urgent - 1 hours)

which is the result or action when one hour has passed of issues assigned with urgent priority ?¿

Thanks

cas

cas

2012-11-23 12:16

reporter   ~0034371

Result is that it will show overdue. If you have this field added to the View Issues page, it will show up in red

Rikard03

Rikard03

2012-11-26 02:44

reporter   ~0034389

Hi Cas,

Thanks for your Help!. A question, For see this field, its necessary to activate a parameters in (config_inc.php)?¿ or simply added the field to the View Issues Page.

Please, if possible you explain as i have to add this field and how to connect it to the plugin SetDueDate.

Thanks very much.

Rikard03

Rikard03

2012-11-26 03:06

reporter   ~0034391

Hi Cas,

Sorry, I have been enabled the parameters for see the flag in the overdue, it`s OK.

But, is there any way we could get a statistic or report of these parameters have been defined according to a resolution of priority of issues.

Thanks,

cas

cas

2012-11-27 07:04

reporter   ~0034405

Sorry, it is not clear to me what kind of report you need. Can you be more precise?

Rikard03

Rikard03

2012-11-27 07:18

reporter   ~0034406

Hi Cas,

For example, a report ad hoc for the plugin.

by the way, I have detected a bug, can you see the issue (0015239.

Thanks,

santy143all

santy143all

2012-11-27 08:22

reporter   ~0034407

Hi cas and all but in filters the value set remain there ubtill they get change but i want when i add a bug with one id in report that should be store in it and next time when i come back t add bug that value should be there by default.

Can anyone please help me with same

Rikard03

Rikard03

2012-11-30 07:13

reporter   ~0034431

Hi @Forgotten

It is possible to send me your version of SetDueDate or attach in this issues.

Thanks,

llaumgui

llaumgui

2013-03-11 11:10

reporter   ~0035429

Hi,

currently, I work on a fork of SetDuedate with :

  • Freeze / unfreeze support
  • Counter
  • By severity
  • Working hour support
  • etc...

It's will be avalaible on github.

Thx

atnz

atnz

2015-04-20 15:52

reporter   ~0050566

Can you post the Github link please?

atnz

atnz

2015-05-05 06:18

reporter   ~0050695

Any chance these issues could make it into v1.3?

atrol

atrol

2015-05-05 10:25

developer   ~0050698

Any chance these issues could make it into v1.3?
I don't think so, because

  • This is a 3rd party plugin at the moment. It does not follow our coding rules. I assume also that it's not tested with different data bases, operating systems, web servers, browsers, ...
  • MantisBT 1.3 Beta 2 has been released, which means that there are no data base schema changes allowed until final release. The plugins however adds a table to the database.
    ...
atnz

atnz

2015-05-05 15:39

reporter   ~0050700

OK, thanks for the reply. Has anyone built an interface for Scrumdesk or similar?

I also attached a spreadsheet we used a while back to calculate burndown.

atnz

atnz

2015-05-05 15:39

reporter   ~0050701

https://www.mantisbt.org/bugs/view.php?id=7945

vboctor

vboctor

2016-03-17 03:25

manager   ~0052789

See the following PR for native support for such feature:
https://github.com/mantisbt/mantisbt/pull/739

Issue History

Date Modified Username Field Change
2010-11-09 06:12 cas New Issue
2010-11-09 06:12 cas File Added: SetDuedate.zip
2011-01-10 00:40 atnz Note Added: 0027866
2011-01-10 00:48 atnz Note Added: 0027867
2011-01-23 14:36 atnz Sponsorship Added atnz: US$ 50
2011-01-23 14:36 atnz Sponsorship Total 0 => 50
2011-01-23 14:36 atnz Note Added: 0028036
2011-03-02 02:30 cas File Added: SetDuedate20.zip
2011-03-02 02:31 cas Note Added: 0028337
2011-03-03 02:58 cas File Added: SetDuedate21.zip
2011-03-03 02:58 cas Note Added: 0028355
2011-03-03 11:27 cas File Added: SetDuedate211.zip
2011-03-03 11:27 cas Note Added: 0028361
2011-04-10 17:13 cor3huis Note Added: 0028581
2011-04-11 03:09 cas Note Added: 0028584
2011-04-11 11:00 cor3huis Note Added: 0028588
2012-05-15 07:18 cas Note Added: 0031839
2012-06-05 06:02 cas File Added: SetDuedate30.zip
2012-06-05 06:04 cas Note Added: 0032014
2012-07-04 05:37 cas File Added: SetDuedate310.zip
2012-07-04 05:38 cas Note Added: 0032247
2012-08-29 09:05 Forgotten Note Added: 0032698
2012-08-29 09:47 atrol Relationship added related to 0013794
2012-08-29 09:54 cas Note Added: 0032699
2012-08-29 10:21 Forgotten Note Added: 0032700
2012-08-29 10:23 Forgotten Note Edited: 0032700 View Revisions
2012-08-30 04:22 cas File Added: SetDuedate320.zip
2012-08-30 04:23 cas Note Added: 0032704
2012-08-30 05:53 cas Note Edited: 0032704 View Revisions
2012-08-30 08:39 Forgotten Note Added: 0032727
2012-08-31 08:27 Forgotten Note Added: 0032744
2012-08-31 08:58 cas Note Added: 0032747
2012-09-07 05:02 Forgotten Note Added: 0032810
2012-09-07 07:32 cas Note Added: 0032812
2012-09-07 08:28 Forgotten File Added: SetDuedate330.zip
2012-09-28 10:35 llaumgui Note Added: 0032984
2012-09-29 03:35 cas Note Added: 0032989
2012-11-23 05:07 Rikard03 Note Added: 0034363
2012-11-23 05:08 Rikard03 Note Edited: 0034363 View Revisions
2012-11-23 12:16 cas Note Added: 0034371
2012-11-26 02:44 Rikard03 Note Added: 0034389
2012-11-26 03:06 Rikard03 Note Added: 0034391
2012-11-26 07:00 dregad Relationship added has duplicate 0015239
2012-11-26 07:01 dregad Relationship replaced related to 0015239
2012-11-27 07:04 cas Note Added: 0034405
2012-11-27 07:18 Rikard03 Note Added: 0034406
2012-11-27 08:22 santy143all Note Added: 0034407
2012-11-30 07:13 Rikard03 Note Added: 0034431
2013-03-11 11:10 llaumgui Note Added: 0035429
2013-03-11 17:08 dregad Relationship added has duplicate 0015591
2013-03-13 06:17 jayavel Issue cloned: 0015618
2013-03-28 06:21 atrol Relationship added related to 0010211
2015-04-20 15:52 atnz Note Added: 0050566
2015-05-05 06:18 atnz Note Added: 0050695
2015-05-05 10:25 atrol Note Added: 0050698
2015-05-05 15:39 atnz Note Added: 0050700
2015-05-05 15:39 atnz Note Added: 0050701
2016-03-17 03:25 vboctor Assigned To => community
2016-03-17 03:25 vboctor Status new => assigned
2016-03-17 03:25 vboctor Note Added: 0052789
2016-03-17 03:31 vboctor Relationship added related to 0020711
2017-01-22 17:02 atrol Status assigned => resolved
2017-02-03 10:33 atrol Status resolved => closed