View Issue Details

IDProjectCategoryView StatusLast Update
0012545mantisbthtmlpublic2015-06-14 09:09
Reporterdhx Assigned Todhx  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version1.3.0-beta.1 
Summary0012545: Output XHTML strict so browsers can validate the output of MantisBT
Description

We should be using XHTML strict for the pages served up by MantisBT so that browsers can quickly ensure that the MantisBT pages are valid/don't contain errors.

This will require quite a fair bit of trial and error testing from the developer end to ensure that the XHTML markup is valid on all pages.

Note: this WILL cause breakages - it's meant to. This is the only way to really discover errors in the output we're sending to clients. Plugins are affected too and need to be sending XHTML strict output as well.

TagsNo tags attached.

Relationships

parent of 0012570 closeddhx print_api and file_api produces invalid xhtml code 
parent of 0012610 closeddhx my_view_page.php: error on line 347 at column 10: Opening and ending tag mismatch: tr line 0 and table 
parent of 0012641 closeddhx content-type not valid for IE 
related to 0012688 closeddhx Tidy non compliance (errors / warnings) 
related to 0015446 closeddregad Using allowed html tags in text fields causes XML parse errors 
related to 0019838 closeddregad Links broken on roadmap page 

Activities

dregad

dregad

2013-10-09 12:46

developer   ~0038236

Setting this as won't fix, since the change was actually reverted, and remove fixed in / target versions so it doesn't show in changelog/roadmap anymore.

Related Changesets

MantisBT: master 4fc1d8b8

2010-11-19 23:53:23

dhx

Details Diff
Issue 0012545: Enforce XHTML strict output for all pages served

We should be using XHTML strict for the pages served up by MantisBT so
that browsers can quickly ensure that the MantisBT pages are valid/don't
contain errors.

This will require quite a fair bit of trial and error testing from the
developer end to ensure that the XHTML markup is valid on all pages.

Note: this WILL cause breakages - it's meant to. This is the only way to
really discover errors in the output we're sending to clients. Plugins
are affected too and need to be sending XHTML strict output as well.
Affected Issues
0012545
mod - core/http_api.php Diff File
mod - core/html_api.php Diff File

MantisBT: master c0a2944f

2010-11-20 03:18:45

dhx

Details Diff
Fix 0012545: Don't use ampersands directly in href attributes

Well formed XHTML doesn't allow the use of ampersands in attributes. We
must therefore use & instead of &.
Affected Issues
0012545
mod - roadmap_page.php Diff File
mod - core/print_api.php Diff File
mod - bug_relationship_graph.php Diff File
mod - core/filter_api.php Diff File
mod - admin/check/index.php Diff File

MantisBT: master 16e9336c

2010-11-20 03:22:28

dhx

Details Diff
Fix 0012545: manage_tags_page: close open <a> tag

If using a hyperlink element (<a>) as a bookmark anchor then we need to
ensure it is properly closed.
Affected Issues
0012545
mod - manage_tags_page.php Diff File

MantisBT: master cb44a76e

2010-11-20 03:49:40

dhx

Details Diff
Issue 0012545: MantisGraph: refactor bug_graph_page.php

bug_graph_page.php needs some refactoring to produce well formed XHTML
output. It also needed some documentation updates and conversion to the
newer require_* API calls.
Affected Issues
0012545
mod - plugins/MantisGraph/pages/bug_graph_page.php Diff File

MantisBT: master 33043bc4

2010-11-20 04:05:03

dhx

Details Diff
Fix 0012545: Refactor print_timezone_option_list()

This function was not producing well formed XHTML due to missing closing
tags on the <optgroup> elements. It was also neglecting to send line
breaks and tabs to the output engine for each option printed, causing
very long lines to appear in the XHTML output. Shorter lines are easier
to read through and debug.
Affected Issues
0012545
mod - account_prefs_inc.php Diff File
mod - core/print_api.php Diff File

MantisBT: master 0fea46fc

2010-11-20 04:29:32

dhx

Details Diff
Fix 0012545: Refactor custom field radio/checkbox fields

We should be using well formed XHTML to generate the list of radio and
checkbox options for the radio and checkbox custom field types. Input
elements should be properly closed. Labels should be used instead of
floating text for labelling each option (this improves usability and
accessibility).
Affected Issues
0012545
mod - core/cfdefs/cfdef_standard.php Diff File

MantisBT: master 7161efed

2010-11-20 04:40:01

dhx

Details Diff
Fix 0012545: Relationship graph output should use cmapx instead of cmap

The dot utility of Graphviz has -Tcmap and -Tcmapx output options that
correspond to HTML and XHTML output respectively. We should be using
"cmapx" to ensure that we're outputting a valid XHTML map element.

This commit also fixes incorrect permissions on graphviz_api.php
(removed execute bits).
Affected Issues
0012545
mod - core/relationship_graph_api.php Diff File

MantisBT: master 374ee370

2010-11-20 04:51:56

dhx

Details Diff
Fix 0012545: Escape strings used in custom enumerations before use

Some of the dropdown boxes used for showing custom enumeration fields
did not make an attempt to escape the administrator-specified
enumeration values. Therefore a custom enumeration value of "< 1 day"
for the ETA field would break the XHTML well formed output.
Affected Issues
0012545
mod - core/print_api.php Diff File

MantisBT: master c75e5d3b

2010-11-20 05:05:19

dhx

Details Diff
Fix 0012545: Make some corrections to custom field radio/checkbox output

Commit 0fea46fcda274ba9349db6091e875bb011cf11ec refactored the output of
radio and checkbox custom fields. However this refactoring introduced an
error with submitting radio fields (the name attribute should not be an
array). Additionally, currently selected values for the fields were not
being checked automatically. The check_checked() function has been
rewritten (copied from check_selected()) so they both behave the same
and can accept arrays as the first parameter.
Affected Issues
0012545
mod - core/helper_api.php Diff File
mod - core/cfdefs/cfdef_standard.php Diff File

MantisBT: master 97611506

2010-11-20 05:11:19

dhx

Details Diff
Fix 0012545: Escape RSS URL before outputting it to XHTML

main_page.php sets an RSS URL via a <link> tag to link to the RSS feed
of the latest news. The RSS URL should be escaped prior to being
inserted into the XHTML output so that the output remains well formed.
Affected Issues
0012545
mod - core/html_api.php Diff File

MantisBT: master e31c91e0

2010-11-20 05:15:24

dhx

Details Diff
Fix 0012545: XHTML attributes must have values

Well formed XHTML requires all element attributes to have values. In the
case of checkboxes and radio fields this means we need to use
checked="checked".
Affected Issues
0012545
mod - manage_user_edit_page.php Diff File
mod - plugins/XmlImportExport/pages/import.php Diff File

MantisBT: master c2c95ed6

2010-11-20 05:26:14

dhx

Details Diff
Fix 0012545: Refactor manage_proj_edit_page to be XHTML well formed

There were a number of errors in the output from
manage_proj_edit_page.php which led to XHTML parsing errors. A </form>
closing tag was in the wrong place and and <input> tag was unclosed.

Some minor reformatting/spacing of sections of this file has also been
conducted to improve readability.
Affected Issues
0012545
mod - manage_proj_edit_page.php Diff File

MantisBT: master 3574fa69

2010-12-25 04:45:43

dhx

Details Diff
Fix 0012545: print_bug_page.php doesn't close <body> and <html> tags

The HTML page output for print_bug_page.php terminates on a closing
</table> tag. The <body> and <html> tags also needing closing for the
page to produce well formed XHTML output.
Affected Issues
0012545
mod - print_bug_page.php Diff File

MantisBT: master-1.2.x be34e61f

2010-12-25 04:45:43

dhx

Details Diff
Fix 0012545: print_bug_page.php doesn't close <body> and <html> tags

The HTML page output for print_bug_page.php terminates on a closing
</table> tag. The <body> and <html> tags also needing closing for the
page to produce well formed XHTML output.
Affected Issues
0012545
mod - print_bug_page.php Diff File

MantisBT: master 0d602be5

2010-12-25 13:09:09

dhx

Details Diff
Issue 0012545: Rewrite attachment listing and previewing

The output printing of bug attachment listings used to use inline custom
JavaScript code. This commit rewrites the printing of attachment lists
to use collapse_api. collapse_api doesn't use inline JavaScript for
collapsing/expanding content on the page.
Affected Issues
0011826, 0012545
mod - core/print_api.php Diff File
mod - css/default.css Diff File
mod - core/collapse_api.php Diff File

MantisBT: master cb5007da

2010-12-26 02:35:42

dhx

Details Diff
Issue 0012545: Convert admin/check script to produce strict XHTML output

The new administration check script at admin/check/index.php is already
producing XHTML strict output. However, the Content-Type header and
headers within the XHTML output itself were still set for traditional
loose HTML output.
Affected Issues
0012545
mod - admin/check/index.php Diff File

MantisBT: master 471900e2

2010-12-26 03:36:41

dhx

Details Diff
Issue 0012545: Replace &nbsp; with HTML5 compatible &0000160;

Siebrand Mazeland already performed this conversion on the 1.2.x branch
on November 1st 2010 as per commit a256ece0d679c906...

These changes are required with the new XHTML strict ouput enforced in
the 1.3.x branch. A bug existed with the date picker (jscalendar) where
someelement.innerHTML was being set to '&nbsp;' - throwing up an error
in Firefox 4.0 beta 9.
Affected Issues
0012545
mod - signup_page.php Diff File
mod - print_all_bug_page_word.php Diff File
mod - account_sponsor_page.php Diff File
mod - plugins/MantisGraph/core/Period.php Diff File
mod - core/icon_api.php Diff File
mod - login_page.php Diff File
mod - bug_sponsorship_list_view_inc.php Diff File
mod - core/collapse_api.php Diff File
mod - print_bug_page.php Diff File
mod - query_view_page.php Diff File
mod - adm_config_report.php Diff File
mod - print_bugnote_inc.php Diff File
mod - manage_config_email_page.php Diff File
mod - manage_proj_page.php Diff File
mod - proj_doc_page.php Diff File
mod - manage_proj_cat_edit_page.php Diff File
mod - manage_custom_field_edit_page.php Diff File
mod - core/relationship_api.php Diff File
mod - core/print_api.php Diff File
mod - manage_user_page.php Diff File
mod - core/string_api.php Diff File
mod - manage_proj_ver_edit_page.php Diff File
mod - manage_config_work_threshold_page.php Diff File
mod - core/custom_function_api.php Diff File
mod - bug_view_inc.php Diff File
mod - docbook/Admin_Guide/en-US/Project_Management.xml Diff File
mod - docbook/Admin_Guide/en-US/Configuration.xml Diff File
mod - manage_plugin_page.php Diff File
mod - proj_doc_edit_page.php Diff File
mod - core/html_api.php Diff File
mod - view_all_inc.php Diff File
mod - manage_config_workflow_page.php Diff File
mod - adm_permissions_report.php Diff File
mod - core/columns_api.php Diff File
mod - lang/strings_ripoarisch.txt Diff File
mod - core/utility_api.php Diff File
mod - manage_proj_edit_page.php Diff File
mod - view_filters_page.php Diff File
mod - docbook/Admin_Guide/en-US/Page_Descriptions.xml Diff File
mod - lost_pwd_page.php Diff File
mod - core/filter_api.php Diff File
mod - print_all_bug_options_inc.php Diff File
mod - lang/strings_hungarian.txt Diff File
mod - bug_update_advanced_page.php Diff File
mod - javascript/jscalendar/calendar.js Diff File

MantisBT: master bac3bae9

2010-12-26 03:41:18

dhx

Details Diff
Issue 0012545: Replace last remaining <br>'s with <br />

Required for strict XHTML output.
Affected Issues
0012545
mod - admin/install.php Diff File
mod - admin/test_langs.php Diff File

MantisBT: master 246332d4

2010-12-26 03:54:33

dhx

Details Diff
Issue 0012545: Remove deprecated <font> tags from XHTML output

The old <font> HTML tag is deprecated and shouldn't be used.
Affected Issues
0012545
mod - login_page.php Diff File
mod - admin/test_email.php Diff File
mod - admin/test_icons.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/authentication_api.php Diff File
mod - core/print_api.php Diff File
mod - admin/install.php Diff File
mod - admin/test_langs.php Diff File

MantisBT: master 49aac093

2010-12-26 04:01:30

dhx

Details Diff
Issue 0012545: Replace deprecated <b> tags with <strong>

The old HTML <b> tag is deprecated and can be replaced with the <strong>
tag instead. Note that this replacement is not always true - <strong> is
meant to convey contextual meaning rather than just bold text style. For
now we'll just perform the replacement without consideration of whether
the usage of <strong> makes contextual sense in each usage scenario.
Affected Issues
0012545
mod - lang/strings_slovak.txt Diff File
mod - lang/strings_chinese_traditional.txt Diff File
mod - query_delete_page.php Diff File
mod - signup.php Diff File
mod - lang/strings_breton.txt Diff File
mod - lang/strings_ukrainian.txt Diff File
mod - core/print_api.php Diff File
mod - my_view_inc.php Diff File
mod - lang/strings_galician.txt Diff File
mod - lang/strings_russian.txt Diff File
mod - lang/strings_tagalog.txt Diff File
mod - lang/strings_english.txt Diff File
mod - lang/strings_lithuanian.txt Diff File
mod - lang/strings_romanian.txt Diff File
mod - query_delete.php Diff File
mod - lang/strings_swissgerman.txt Diff File
mod - bug_report_page.php Diff File
mod - lang/strings_occitan.txt Diff File
mod - lang/strings_spanish.txt Diff File
mod - lang/strings_bulgarian.txt Diff File
mod - lost_pwd.php Diff File
mod - lang/strings_german.txt Diff File
mod - lang/strings_serbian.txt Diff File
mod - lang/strings_swedish.txt Diff File
mod - lang/strings_dutch.txt Diff File
mod - lang/strings_korean.txt Diff File
mod - admin/index.php Diff File
mod - core/custom_function_api.php Diff File
mod - lang/strings_finnish.txt Diff File
mod - core/relationship_api.php Diff File
mod - lang/strings_polish.txt Diff File
mod - admin/upgrade_warning.php Diff File
mod - lang/strings_macedonian.txt Diff File
mod - lang/strings_chinese_simplified.txt Diff File
mod - lang/strings_slovene.txt Diff File
mod - lang/strings_hungarian.txt Diff File
mod - core.php Diff File
mod - core/config_api.php Diff File
mod - lang/strings_portuguese_brazil.txt Diff File
mod - lang/strings_urdu.txt Diff File
mod - lang/strings_danish.txt Diff File
mod - lang/strings_italian.txt Diff File
mod - lang/strings_estonian.txt Diff File
mod - bugnote_edit_page.php Diff File
mod - lang/strings_catalan.txt Diff File
mod - lang/strings_hebrew.txt Diff File
mod - tests/soap/IssueAddTest.php Diff File
mod - core/error_api.php Diff File
mod - lang/strings_czech.txt Diff File
mod - lang/strings_arabicegyptianspoken.txt Diff File
mod - lang/strings_japanese.txt Diff File
mod - lang/strings_arabic.txt Diff File
mod - lang/strings_icelandic.txt Diff File
mod - lang/strings_french.txt Diff File

MantisBT: master 6f0f5930

2010-12-26 04:05:47

dhx

Details Diff
Issue 0012545: Remove deprecated <u> tag from account_sponsorship_page

The old HTML <u> tag is deprecated and has no direct replacement. We
should be using CSS for styling instead.
Affected Issues
0012545
mod - account_sponsor_page.php Diff File

MantisBT: master 9f6433e1

2010-12-26 04:23:53

dhx

Details Diff
Issue 0012545: Remove duplicate form closing tag (bug actiongroup)

A duplicate </form> closing tag existed on bug_actiongroup_page. This
led to XHTML validation errors in the browser due to the malformed XHTML
markup.
Affected Issues
0012545
mod - core/bug_group_action_api.php Diff File

MantisBT: master 90cc5cc1

2010-12-26 05:26:13

dhx

Details Diff
Issue 0012545: Remove deprecated <center> tag, align and valign attrs

The following features of old school HTML are deprecated:
* <center></center>
* align="center"
* valign="top"

This commit removes those deprecated HTML tags and attributes and
replaces them with equivalent CSS in some parts. This commit does break
the layout in many places (things no longer center align) so some follow
up will be needed when we start to remove table based layouts.
Affected Issues
0012545
mod - manage_config_columns_set.php Diff File
mod - core/helper_api.php Diff File
mod - lost_pwd_page.php Diff File
mod - permalink_page.php Diff File
mod - bug_actiongroup_add_note_inc.php Diff File
mod - account_prefs_update.php Diff File
mod - proj_doc_delete.php Diff File
mod - news_view_page.php Diff File
mod - print_bugnote_inc.php Diff File
mod - bug_actiongroup_ext_page.php Diff File
mod - bug_actiongroup.php Diff File
mod - manage_tags_page.php Diff File
mod - manage_proj_create_page.php Diff File
mod - core/error_api.php Diff File
mod - account_sponsor_update.php Diff File
mod - bug_actiongroup_update_product_build_inc.php Diff File
mod - manage_config_email_set.php Diff File
mod - admin/system_utils.php Diff File
mod - manage_user_create.php Diff File
mod - account_prof_edit_page.php Diff File
mod - manage_user_reset.php Diff File
mod - manage_proj_ver_update.php Diff File
mod - tag_attach.php Diff File
mod - bug_reminder_page.php Diff File
mod - manage_proj_ver_edit_page.php Diff File
mod - manage_config_revert.php Diff File
mod - signup.php Diff File
mod - manage_overview_page.php Diff File
mod - manage_config_workflow_set.php Diff File
mod - my_view_page.php Diff File
mod - admin/upgrade_warning.php Diff File
mod - bug_view_inc.php Diff File
mod - manage_user_create_page.php Diff File
mod - proj_doc_edit_page.php Diff File
mod - print_all_bug_options_reset.php Diff File
mod - manage_proj_ver_delete.php Diff File
mod - manage_config_columns_reset.php Diff File
mod - core/bug_group_action_api.php Diff File
mod - manage_proj_cat_edit_page.php Diff File
mod - manage_proj_custom_field_remove.php Diff File
mod - plugins/MantisGraph/pages/summary_jpgraph_page.php Diff File
mod - proj_doc_add_page.php Diff File
mod - core/html_api.php Diff File
mod - proj_doc_page.php Diff File
mod - summary_page.php Diff File
mod - manage_proj_page.php Diff File
mod - manage_proj_ver_add.php Diff File
mod - set_project.php Diff File
mod - manage_proj_subproj_add.php Diff File
mod - lost_pwd.php Diff File
mod - login_select_proj_page.php Diff File
mod - core/print_api.php Diff File
mod - account_sponsor_page.php Diff File
mod - bugnote_edit_page.php Diff File
mod - bug_actiongroup_update_severity_inc.php Diff File
mod - manage_user_delete.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_status.php Diff File
mod - core/relationship_api.php Diff File
mod - manage_proj_user_remove.php Diff File
mod - plugins/MantisCoreFormatting/pages/config.php Diff File
mod - view_filters_page.php Diff File
mod - adm_config_report.php Diff File
mod - manage_user_edit_page.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_resolution.php Diff File
mod - news_edit_page.php Diff File
mod - bug_change_status_page.php Diff File
mod - login_page.php Diff File
mod - account_prefs_inc.php Diff File
mod - bug_reminder.php Diff File
mod - docbook/Developers_Guide/en-US/Plugins_Building.xml Diff File
mod - core/access_api.php Diff File
mod - manage_proj_subproj_delete.php Diff File
mod - plugins/MantisGraph/pages/config.php Diff File
mod - manage_proj_custom_field_update.php Diff File
mod - print_all_bug_page_word.php Diff File
mod - main_page.php Diff File
mod - signup_page.php Diff File
mod - bug_actiongroup_page.php Diff File
mod - manage_custom_field_edit_page.php Diff File
mod - query_store_page.php Diff File
mod - manage_proj_custom_field_add_existing.php Diff File
mod - core/summary_api.php Diff File
mod - docbook/Developers_Guide/en-US/Plugins_Building_Source.xml Diff File
mod - bug_report_page.php Diff File
mod - my_view_inc.php Diff File
mod - manage_proj_edit_page.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_severity.php Diff File
mod - manage_custom_field_update.php Diff File
mod - manage_proj_create.php Diff File
mod - manage_user_proj_delete.php Diff File
mod - query_view_page.php Diff File
mod - proj_doc_add.php Diff File
mod - manage_user_page.php Diff File
mod - admin/install.php Diff File
mod - print_all_bug_page.php Diff File
mod - bug_file_add.php Diff File
mod - account_page.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_priority.php Diff File
mod - manage_custom_field_delete.php Diff File
mod - account_delete.php Diff File
mod - news_add.php Diff File
mod - manage_custom_field_create.php Diff File
mod - manage_proj_cat_update.php Diff File
mod - core/filter_api.php Diff File
mod - manage_user_update.php Diff File
mod - print_all_bug_options_update.php Diff File
mod - query_delete_page.php Diff File
mod - bug_report.php Diff File
mod - proj_doc_update.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_category.php Diff File
mod - manage_config_work_threshold_set.php Diff File
mod - news_menu_page.php Diff File
mod - bug_update_advanced_page.php Diff File
mod - core/authentication_api.php Diff File
mod - manage_proj_cat_delete.php Diff File
mod - account_prof_menu_page.php Diff File
mod - bug_actiongroup_ext.php Diff File
mod - admin/index.php Diff File
mod - news_update.php Diff File
mod - view_user_page.php Diff File
mod - account_update.php Diff File
mod - query_delete.php Diff File
mod - print_all_bug_options_inc.php Diff File
mod - manage_columns_inc.php Diff File
mod - view_all_inc.php Diff File

MantisBT: master aa04132f

2010-12-26 05:33:04

dhx

Details Diff
Issue 0012545: Remove deprecated border attribute

The old HTML border="0" attribute is deprecated and should be removed.
CSS border properties can be used instead if borders are required.
Affected Issues
0012545
mod - admin/test_email.php Diff File
mod - admin/upgrade_warning.php Diff File
mod - admin/move_db2disk.php Diff File
mod - plugins/MantisGraph/MantisGraph.php Diff File
mod - core/html_api.php Diff File
mod - print_all_bug_page.php Diff File
mod - billing_inc.php Diff File
mod - admin/copy_field.php Diff File
mod - core/relationship_api.php Diff File
mod - print_bug_page.php Diff File
mod - manage_user_page.php Diff File
mod - core/print_api.php Diff File
mod - print_all_bug_page_word.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_status.php Diff File
mod - core/collapse_api.php Diff File
mod - admin/install.php Diff File
mod - my_view_inc.php Diff File
mod - core/columns_api.php Diff File
mod - bug_sponsorship_list_view_inc.php Diff File
mod - my_view_page.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_severity.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_priority.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_resolution.php Diff File
mod - bugnote_stats_inc.php Diff File
mod - plugins/MantisGraph/pages/summary_jpgraph_page.php Diff File
mod - admin/system_utils.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_category.php Diff File

MantisBT: master 096b8c20

2010-12-26 05:36:34

dhx

Details Diff
Issue 0012545: Replace deprecated <strike> tag with CSS equivalent

The old HTML <strike> tag is deprecated and should be replaced with a
CSS equivalent.
Affected Issues
0012545
mod - core/custom_function_api.php Diff File

MantisBT: master 58f8ad2a

2010-12-26 05:40:16

dhx

Details Diff
Issue 0012545: Remove deprecated clear attribute

Older versions of HTML allowed for a "clear" attribute. This is now
deprecated and should be removed. Only one instance of this attribute
was used on print_all_bug_page_word.php and it wasn't really required
anyway.
Affected Issues
0012545
mod - print_all_bug_page_word.php Diff File

MantisBT: master 3045096d

2010-12-26 05:44:24

dhx

Details Diff
Issue 0012545: Replace deprecated nowrap attribute with CSS equivalent

The old HTML "nowrap" attribute is deprecated and should be replaced
with a CSS equivalent approach.
Affected Issues
0012545
mod - my_view_inc.php Diff File
mod - admin/upgrade_warning.php Diff File
mod - core/filter_api.php Diff File

MantisBT: master 6a0714fe

2010-12-26 05:50:36

dhx

Details Diff
Issue 0012545: Remove deprecated size and width attributes from <hr>

The "size" and "width" attributes of HTML are deprecated and therefore
should not be used on <hr /> elements. CSS can be used instead if
necessary (in almost all cases there is no need for CSS customisation of
<hr /> however).
Affected Issues
0012545
mod - core/helper_api.php Diff File
mod - print_all_bug_page_word.php Diff File
mod - print_bugnote_inc.php Diff File
mod - core/print_api.php Diff File
mod - print_bug_page.php Diff File

MantisBT: master ec574f8c

2013-06-07 05:21:13

dregad

Details Diff
Revert "Issue 0012545: Enforce XHTML strict output for all pages served"

This reverts commit 4fc1d8b8290872e660c6d9a179c4c2209adf7e26.

Fixes 0013304, 0014759, 0015446

Conflicts:

core/http_api.php
Affected Issues
0012545, 0013304, 0014759, 0015446
mod - core/html_api.php Diff File
mod - core/http_api.php Diff File

Issue History

Date Modified Username Field Change
2010-11-19 18:58 dhx New Issue
2010-11-19 18:58 dhx Status new => assigned
2010-11-19 18:58 dhx Assigned To => dhx
2010-11-20 00:28 dhx Changeset attached => MantisBT master c2c95ed6
2010-11-20 00:28 dhx Changeset attached => MantisBT master e31c91e0
2010-11-20 00:28 dhx Changeset attached => MantisBT master 97611506
2010-11-20 00:28 dhx Changeset attached => MantisBT master c75e5d3b
2010-11-20 00:28 dhx Changeset attached => MantisBT master 374ee370
2010-11-20 00:28 dhx Changeset attached => MantisBT master 7161efed
2010-11-20 00:28 dhx Changeset attached => MantisBT master 0fea46fc
2010-11-20 00:28 dhx Changeset attached => MantisBT master 33043bc4
2010-11-20 00:28 dhx Changeset attached => MantisBT master cb44a76e
2010-11-20 00:28 dhx Changeset attached => MantisBT master 16e9336c
2010-11-20 00:28 dhx Changeset attached => MantisBT master c0a2944f
2010-11-20 00:28 dhx Changeset attached => MantisBT master 4fc1d8b8
2010-11-20 00:28 dhx Resolution open => fixed
2010-11-20 00:28 dhx Fixed in Version => 1.3.0-beta.1
2010-11-30 08:51 dhx Relationship added parent of 0012570
2010-12-14 19:43 dhx Relationship added parent of 0012610
2010-12-24 23:54 dhx Changeset attached => MantisBT master 3574fa69
2010-12-24 23:54 dhx Changeset attached => MantisBT master-1.2.x be34e61f
2010-12-25 08:17 dhx Changeset attached => MantisBT master 0d602be5
2010-12-25 21:44 dhx Changeset attached => MantisBT master cb5007da
2010-12-25 22:46 dhx Changeset attached => MantisBT master bac3bae9
2010-12-25 22:46 dhx Changeset attached => MantisBT master 471900e2
2010-12-26 00:58 dhx Changeset attached => MantisBT master 6a0714fe
2010-12-26 00:58 dhx Changeset attached => MantisBT master 3045096d
2010-12-26 00:58 dhx Changeset attached => MantisBT master 58f8ad2a
2010-12-26 00:58 dhx Changeset attached => MantisBT master 096b8c20
2010-12-26 00:58 dhx Changeset attached => MantisBT master aa04132f
2010-12-26 00:58 dhx Changeset attached => MantisBT master 90cc5cc1
2010-12-26 00:58 dhx Changeset attached => MantisBT master 9f6433e1
2010-12-26 00:58 dhx Changeset attached => MantisBT master 6f0f5930
2010-12-26 00:58 dhx Changeset attached => MantisBT master 49aac093
2010-12-26 00:58 dhx Changeset attached => MantisBT master 246332d4
2010-12-26 07:54 dhx Changeset attached => MantisBT master adf2338a
2010-12-26 07:54 dhx Changeset attached => MantisBT master 7a6fba7c
2010-12-26 07:55 dhx Changeset removed MantisBT master 7a6fba7c =>
2010-12-26 07:56 dhx Changeset removed MantisBT master adf2338a =>
2010-12-31 01:46 dhx Relationship added parent of 0012641
2011-01-11 21:05 dhx Relationship added parent of 0012679
2011-01-11 21:07 dhx Relationship deleted parent of 0012679
2011-01-15 08:37 dhx Relationship added related to 0012688
2013-01-30 16:05 atrol Relationship added related to 0015446
2013-04-06 03:44 dregad Status assigned => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2013-10-09 11:03 dregad Changeset attached => MantisBT master ec574f8c
2013-10-09 12:46 dregad Note Added: 0038236
2013-10-09 12:46 dregad Resolution fixed => won't fix
2013-10-09 12:46 dregad Fixed in Version 1.3.0-beta.1 =>
2013-10-09 12:46 dregad Target Version 1.3.0-beta.1 =>
2013-10-18 20:24 atrol Status resolved => closed
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2015-06-14 09:09 atrol Relationship added related to 0019838