View Issue Details

IDProjectCategoryView StatusLast Update
0012664mantisbtfilterspublic2018-07-15 12:13
ReporterpimbollenAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.4 
Target VersionFixed in Version 
Summary0012664: hide_status_id in permalink not working
Description

When creating a filter with hide status set to resolved (and above) for example and creating a permalink, using the link shows all the items.

Steps To Reproduce

An example of a created permalink is:
http://######/mantis/search.php?project_id=36&sticky_issues=1&sortby=last_updated&dir=DESC&hide_status_id=80
Use the project_id of one of your projects to test.

TagsNo tags attached.

Relationships

related to 0006042 closedcproensa Switching to "Advanced Filters" hides "Hide Status" and ignores setting 
has duplicate 0014730 closedatrol Permalinks don't contain enough information 

Activities

rnelson0

rnelson0

2013-02-13 10:47

reporter   ~0035126

atrol, any update on this bug? I am running 1.2.4 and would like to know if this is fixed in the latest production build.

atrol

atrol

2013-02-13 16:53

developer   ~0035132

rnelson0, have a look at the field values which reflect the current state: The issue is not fixed in latest production build.

Status = 'confirmed', Resolution = 'open', Fixed in Version = ''

rnelson0

rnelson0

2013-02-13 21:23

reporter   ~0035134

Is there a timeframe for the fix, or a workaround that can be implemented on a per-install basis?

jhcaiced

jhcaiced

2013-06-12 11:31

reporter   ~0037170

I have just found this same issue in 1.2.15, it is not fixed yet.

atrol

atrol

2018-07-05 17:43

developer   ~0060221

pimbollen,

I was no longer able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.15.0 at the moment).

I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue.
[1] http://mantisbt.org/download.php

Issue History

Date Modified Username Field Change
2011-01-07 07:17 pimbollen New Issue
2011-01-07 09:08 atrol Relationship added related to 0006042
2012-09-21 16:53 atrol Relationship added has duplicate 0014730
2012-09-21 16:55 atrol Status new => confirmed
2013-02-13 10:47 rnelson0 Note Added: 0035126
2013-02-13 16:53 atrol Note Added: 0035132
2013-02-13 21:23 rnelson0 Note Added: 0035134
2013-06-12 11:31 jhcaiced Note Added: 0037170
2018-07-05 17:43 atrol Assigned To => atrol
2018-07-05 17:43 atrol Status confirmed => resolved
2018-07-05 17:43 atrol Resolution open => fixed
2018-07-05 17:43 atrol Note Added: 0060221
2018-07-15 12:13 atrol Status resolved => closed