View Issue Details

IDProjectCategoryView StatusLast Update
0014730mantisbtfilterspublic2018-07-15 12:13
ReporterrilligAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.11 
Target VersionFixed in Version 
Summary0014730: Permalinks don't contain enough information
Description

When I create a Permalink for some search criteria and then click on the link, the search criteria are not what they were before the Permalink.

  1. Log in to http://mantisbt.org/demo/
  2. Go to http://mantisbt.org/demo/view_all_bug_page.php
  3. Select [Reset Filter] and click on [Use Filter]
  4. Click on [Create Permalink]
  5. Click on the generated Permalink
  6. Compare the new search criteria with the old search criteria

In the old search criteria the "Hide Status" was "closed (and above)".
In the new search criteria the "Hide Status" is missing completely. What does that even mean?

In the old search criteria the "Project" was missing completely.
In the new search criteria the "Project" is set to "All Projects".

Due to these differences (and maybe some other fields) the search results for the old and new criteria differ as well.

Additional Information

The demo installation at http://mantisbt.org/demo/ doesn't reveal its version number. That's bad. I hope it's a pretty recent version so that bugs reported against it are valid.

TagsNo tags attached.

Relationships

duplicate of 0012664 closedatrol hide_status_id in permalink not working 
related to 0012323 confirmed Permalink creation does not save top right project filter (near Switch button) 
related to 0009410 confirmed Permalink shows fewer issues than original filter did 

Activities

atrol

atrol

2012-09-21 16:53

developer   ~0032905

In the old search criteria the "Hide Status" was "closed (and above)".
In the new search criteria the "Hide Status" is missing completely. What does that even mean?
This is a duplicate of 0012664

In the old search criteria the "Project" was missing completely.
In the new search criteria the "Project" is set to "All Projects".
This is related to 0012323

Both issues are also caused by the fact that following our links will always lead to "Advanded Filters" page, even when created on "Simple Filter" page.

atrol

atrol

2018-07-05 17:47

developer   ~0060222

rillig,

I was no longer able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.15.0 at the moment).

I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue.
[1] http://mantisbt.org/download.php

Issue History

Date Modified Username Field Change
2012-09-21 16:05 rillig New Issue
2012-09-21 16:53 atrol Note Added: 0032905
2012-09-21 16:53 atrol Relationship added duplicate of 0012664
2012-09-21 16:53 atrol Relationship added related to 0012323
2012-09-21 16:54 atrol Status new => confirmed
2012-09-21 16:54 atrol Category csv => filters
2012-09-21 16:54 atrol Product Version => 1.2.11
2012-10-11 13:54 atrol Relationship added related to 0009410
2018-07-05 17:47 atrol Assigned To => atrol
2018-07-05 17:47 atrol Status confirmed => resolved
2018-07-05 17:47 atrol Resolution open => fixed
2018-07-05 17:47 atrol Note Added: 0060222
2018-07-15 12:13 atrol Status resolved => closed