View Issue Details

IDProjectCategoryView StatusLast Update
0012769mantisbtchange logpublic2011-08-05 02:41
Reportermark.badolato Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.4 
Summary0012769: Change log does not list tickets from sub-projects
Description

In my setup, I have some projects defined and I have subprojects underneath them.

If I set a release on a ticket that is at the project level, it shows up in the change log as it's supposed to. If I do it to a ticket in a subproject, that ticket doesn't appear in the change log.

The Fixed In dropdown shows [mainproject_name release_name], but the change log doesn't display appropriately.

TagsNo tags attached.

Relationships

duplicate of 0010873 closeddregad Change Log/Roadmap do not work with inherited versions. 

Activities

mark.badolato

mark.badolato

2011-02-17 17:28

reporter   ~0028252

Looks like this issue applies to Roadmaps too. Bugs tagged with a Target Version for a parent project show up in the road map, bugs tagged with a target version for a sub project do not

atrol

atrol

2011-02-18 02:22

developer   ~0028253

I think this is a dpulicate of 0010873
Do you agree?

mark.badolato

mark.badolato

2011-02-28 14:17

reporter   ~0028319

Agreed; Appears to be the same issue

cor3huis

cor3huis

2011-04-09 09:24

reporter   ~0028577

Goal: A roadmap page which also shows the roadmap of sub-projects on the page

I did test it on version 1.2.5 Git of 20110408 an the roadmap worked for sub-projects, Great!

I had:

PROJ_A
SUBROJ_X

PROJ_B
SUBROJ_X

Make sure you have:

  • A project with versions
  • Issues in the tracker that are not resolved
  • A Target Version set in every issue
  • A Viewable Project

One of the main thin to keep in mind that a roadmap is a Project bound to Version and Deliverydate. If one has no target version set it will an cannot show in the roadmap ofcourse.

If somethisn does not work since you upgraded from older versions then thes things might help:

  • Subproject inheritance

    Click button: Update subproject inheritance

    Then it does work, fine you are done!.

*Unlink

Unlink everythin first, set your version, then relink the sub-project
press [Unlink ]

Select all

update target version of a version in the dropdown

Now make it a sub-project again

...it works, than good. If id dioes not make sure you understand mantis and roadmap concept well, and try again with a new Project and subproject.

Notes:

Ensure you have set the config "$g_roadmap_view_threshold" to something good (e.g. VIEWER)

Issue History

Date Modified Username Field Change
2011-02-14 18:24 mark.badolato New Issue
2011-02-17 17:28 mark.badolato Note Added: 0028252
2011-02-18 02:22 atrol Note Added: 0028253
2011-02-18 02:22 atrol Status new => feedback
2011-02-28 14:17 mark.badolato Note Added: 0028319
2011-02-28 14:17 mark.badolato Status feedback => new
2011-02-28 14:36 atrol Relationship added duplicate of 0010873
2011-02-28 14:36 atrol Status new => resolved
2011-02-28 14:36 atrol Resolution open => duplicate
2011-02-28 14:36 atrol Assigned To => atrol
2011-04-09 09:24 cor3huis Note Added: 0028577
2011-08-05 02:41 atrol Status resolved => closed