View Issue Details

IDProjectCategoryView StatusLast Update
0013181mantisbtldappublic2020-01-10 17:43
ReporterSL-Gundam Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPHP 5.3.3 ntsOSWindows 7 x64OS Version6.1 (Build 7600)
Product Version1.2.6 
Target Version1.2.7Fixed in Version1.2.7 
Summary0013181: ldap_port obsolete... but not anymore?
Description

In 0012167 the "not using" of ldap_port was addressed. But the mantis "Check installation" within the admin pages has been saying for some time now:


Warning: The configuration option $g_ldap_port is now obsolete
please use $g_ldap_server instead.

Now it seems its no longer obsolete. Or did the warning mean that the option was deprecated and would be dropped in future versions but would still be used in 1.2.x?

TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 
related to 0026589 closeddregad Admin Guide: remove doc for long-deprecated $g_ldap_port config 

Activities

grangeway

grangeway

2011-07-27 05:40

reporter   ~0029303

Hi,

The configuration variable ldap_port was removed.

The ldap server variable should be used to specify a port if required.

Thanks
Paul

dregad

dregad

2011-08-02 10:31

developer   ~0029348

Actually I think the problem is due to the fact that $g_ldap_port is still defined in config_defaults_inc.php even though it is obsolete. So when you execute admin/check.php it flags a warning.

atrol

atrol

2011-08-02 12:09

developer   ~0029350

Please have a look at my comment
https://github.com/mantisbt/mantisbt/commit/655d959848d4f45edef48ae4e3099f4f411d8113#commitcomment-508516

dregad

dregad

2011-08-02 12:24

developer   ~0029351

Good catch, thanks atrol. Fixed it.

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036416

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master-1.2.x 655d9598

2011-08-02 07:28:23

dregad

Details Diff
Fix 0013181: Remove obsolete g_ldap_port from config_defaults_inc.php

$g_ldap_port is obsolete since 1.2.0a1, but the variable was not removed from
config_defaults_inc.php, resulting in a false warning in admin/check.php.

This problem was resolved in commit c207d0452631f6f5648e1813c807bce4873acc20
for 1.3.x but the change was never applied to 1.2.x.

This commit removes the obsolete variable, and aligns the comment for
$g_ldap_server to match the same in 1.3.x
Affected Issues
0013181
mod - config_defaults_inc.php Diff File

MantisBT: master-1.2.x 6d8faa56

2011-08-02 09:13:57

dregad

Details Diff
Fix 0013181: Remove obsolete ldap_port from ldap_api.php

See 655d959848d4f45edef48ae4e3099f4f411d8113
Affected Issues
0013181
mod - core/ldap_api.php Diff File