View Issue Details

IDProjectCategoryView StatusLast Update
0014392mantisbtchange logpublic2012-06-29 06:13
Reporterrtoliveira Assigned Todregad  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platform64 bitsOSGNU/Linux 
Product Version1.2.11 
Summary0014392: Change log pag is blank/empty after migration!
Description

Hi!

I created a new server to migrate my currently mantis 1.2.4 (schema 183) installation to the version 1.2.11. My database is MySQL.

Everything is fine, except the change log page. I reproduced this issue with mantis 1.2.10 too.

Steps To Reproduce

Accessing change log page.

Additional Information

Two images is attached, one is

TagsNo tags attached.

Relationships

duplicate of 0010873 closeddregad Change Log/Roadmap do not work with inherited versions. 

Activities

rtoliveira

rtoliveira

2012-06-14 15:06

reporter  

mantis-1.2.4.png (81,347 bytes)   
mantis-1.2.4.png (81,347 bytes)   
rtoliveira

rtoliveira

2012-06-14 15:07

reporter  

mantis-1.2.11.png (45,558 bytes)   
mantis-1.2.11.png (45,558 bytes)   
rtoliveira

rtoliveira

2012-06-14 15:11

reporter   ~0032101

Is it related to http://www.mantisbt.org/bugs/view.php?id=13942 ?

rtoliveira

rtoliveira

2012-06-14 15:18

reporter   ~0032102

The correct image for 1.2.11 version is mantis-1.2.11_CORRECT.png

rtoliveira

rtoliveira

2012-06-14 15:19

reporter  

mantis-1.2.11_CORRECT.png (45,591 bytes)   
mantis-1.2.11_CORRECT.png (45,591 bytes)   
rtoliveira

rtoliveira

2012-06-14 15:21

reporter  

mantis-1.2.4_CORRECT.png (115,486 bytes)   
mantis-1.2.4_CORRECT.png (115,486 bytes)   
rtoliveira

rtoliveira

2012-06-14 15:22

reporter   ~0032103

I attached nother image for 1.2.4 version too

rtoliveira

rtoliveira

2012-06-14 15:31

reporter   ~0032104

Last edited: 2012-06-15 08:11

View 2 revisions

I solved using the hint 3 from 0010873:0026242 neosonicxmantis 2010-08-07 16:41

Solution 3: disable get versions from cache

/core/version_api.php
function version_get_all_rows( $p_project_id, $p_released = null, $p_obsolete = false, $p_inherit = null ) {
// global $g_cache_versions, $g_cache_versions_project;
...

EDIT: direct link to note

dregad

dregad

2012-06-15 08:12

developer   ~0032107

Marking this as duplicate per your latest note

Issue History

Date Modified Username Field Change
2012-06-14 15:06 rtoliveira New Issue
2012-06-14 15:06 rtoliveira File Added: mantis-1.2.4.png
2012-06-14 15:07 rtoliveira File Added: mantis-1.2.11.png
2012-06-14 15:11 rtoliveira Note Added: 0032101
2012-06-14 15:18 rtoliveira Note Added: 0032102
2012-06-14 15:19 rtoliveira File Added: mantis-1.2.11_CORRECT.png
2012-06-14 15:21 rtoliveira File Added: mantis-1.2.4_CORRECT.png
2012-06-14 15:22 rtoliveira Note Added: 0032103
2012-06-14 15:31 rtoliveira Note Added: 0032104
2012-06-14 17:42 grangeway Assigned To => grangeway
2012-06-14 17:42 grangeway Status new => assigned
2012-06-15 08:11 dregad Note Edited: 0032104 View Revisions
2012-06-15 08:12 dregad Note Added: 0032107
2012-06-15 08:12 dregad Relationship added duplicate of 0010873
2012-06-15 08:12 dregad Status assigned => resolved
2012-06-15 08:12 dregad Resolution open => duplicate
2012-06-15 08:12 dregad Assigned To grangeway => dregad
2012-06-29 06:13 atrol Status resolved => closed