View Issue Details

IDProjectCategoryView StatusLast Update
0016995mantisbtdocumentationpublic2014-12-08 02:08
ReporterbadfilesAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.0dev 
Target Version1.3.0-beta.1Fixed in Version 
Summary0016995: Absolute g_manual_url becomes relative on proj_doc_page.php
Description

The default value of g_manual_url (fullpath) becomes part of the link to the manual.

TagsNo tags attached.

Activities

dregad

dregad

2014-02-26 11:59

developer   ~0039558

https://github.com/mantisbt/mantisbt/pull/144

dregad

dregad

2014-06-11 12:33

developer   ~0040795

The documentation page will now build a correct link also for absolute URLs. If a relative path that does not exist is provided, the code falls back to the online manual (http://www.mantisbt.org/documentation.php)

Related Changesets

MantisBT: master b36ac41d

2014-06-02 06:38:08

dregad

Details Diff
Fix absolute URLs issue with 'User Documentation' link

This resolves the issue with absolute URLs specified in $g_manual_url
becoming relative on project documentation pages.

Following discussions in the pull request [1], the solution implements
additional logic in the print_doc_menu() function that checks whether
the provided URL is absolute or relative (based on presence of an URL
scheme):
- if relative, makes sure the local path exists
- if yes, build absolute URL using helper_mantis_url()
- if not, fall back to the online manual on
http://www.mantisbt.org/documentation.php
- if absolute, uses the URL as-is without check

Since this is currently the only use case for absolute URLs with
helper_mantis_url() and the documentation feature is deprecated, it made
more sense to have the logic in print_doc_menu() rather than creating a
new API function.

Fixes 0016995

[1] https://github.com/mantisbt/mantisbt/pull/144
Affected Issues
0016995
mod - config_defaults_inc.php Diff File
mod - core/html_api.php Diff File

Issue History

Date Modified Username Field Change
2014-02-19 06:13 badfiles New Issue
2014-02-26 11:19 dregad Status new => confirmed
2014-02-26 11:19 dregad Product Version git trunk => 1.3.0dev
2014-02-26 11:58 dregad Assigned To => dregad
2014-02-26 11:58 dregad Status confirmed => assigned
2014-02-26 11:59 dregad Note Added: 0039558
2014-06-11 12:28 dregad Changeset attached => MantisBT master b36ac41d
2014-06-11 12:28 dregad Status assigned => resolved
2014-06-11 12:28 dregad Resolution open => fixed
2014-06-11 12:28 dregad Fixed in Version => 1.3.0-beta.1
2014-06-11 12:33 dregad Note Added: 0040795
2014-06-11 12:33 dregad Target Version => 1.3.0-beta.1
2014-11-10 11:09 vboctor Fixed in Version 1.3.0-beta.1 =>
2014-12-08 02:08 atrol Status resolved => closed