View Issue Details

IDProjectCategoryView StatusLast Update
0021801mantisbtuipublic2019-03-16 20:21
ReporterChris_ZAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.3 
Target VersionFixed in Version 
Summary0021801: File attachment GUI allows larger files than permitted
Description

When reporting issue, the user is allowed to select files exceeding the permitted size limit.

When submitting such issue the error is generated and the issue is saved but without attachment.

I think it would be better to warn user much earlier in this workflow: during the file selection.

TagsNo tags attached.

Relationships

related to 0025464 closedcproensa Enforce max-filesize in dropzone to alert and drop big files before form submission 
related to 0003759 confirmed Duplicate bug is created when resubmitting after file upload failure 
related to 0022588 closedcproensa Oversize upload is now skipped with no Message prompted 

Activities

Chris_Z

Chris_Z

2016-10-15 15:30

reporter  

Chris_Z

Chris_Z

2017-03-24 13:23

reporter   ~0056187

There is more to it, it is also an effective way to mute the notification logic.

Just recently one of our Mantis users tried to log an issue with an attachment lager than allowed by the limit set in $g_max_file_size.
He was greeted with an error page asking him to hit Back-key and try again.

He followed the advice and tried again this time putting attachment in the note.
He was once more greeted with an error page asking him to hit Back-key and try again.

Only at third attempt, this time without the attachment, he succeeded.

Not once during first two attempts the issue creation logic generated a notification to those concerned.
If the user gave up after the first two attempts, two (duplicate) issues were created and none of notifications.

In other words: the easiest way to circumvent the notification logic is to create an issue with a huge attachment.
The issue is saved (albeit without attachment) and the notification about issue creation event is effectively muted.

This shouldn't be entirely on the user's discretion I presume?

cproensa

cproensa

2019-03-05 16:47

developer   ~0061635

Resolving, as implemented in related issue: 0025464

thE_iNviNciblE

thE_iNviNciblE

2019-03-10 06:24

reporter   ~0061655

:-)

Issue History

Date Modified Username Field Change
2016-10-15 15:30 Chris_Z New Issue
2016-10-15 15:30 Chris_Z File Added: Snapshot-2016-10-15-212124.png
2017-03-24 13:23 Chris_Z Note Added: 0056187
2017-04-24 17:30 atrol Status new => confirmed
2017-04-24 17:31 atrol Relationship added related to 0022588
2019-03-05 16:45 cproensa Relationship added related to 0025464
2019-03-05 16:46 cproensa Relationship added related to 0003759
2019-03-05 16:47 cproensa Assigned To => cproensa
2019-03-05 16:47 cproensa Status confirmed => resolved
2019-03-05 16:47 cproensa Resolution open => fixed
2019-03-05 16:47 cproensa Note Added: 0061635
2019-03-10 06:24 thE_iNviNciblE Note Added: 0061655
2019-03-16 20:21 vboctor Status resolved => closed