View Issue Details

IDProjectCategoryView StatusLast Update
0022588mantisbtattachmentspublic2019-03-16 20:21
ReportericoamsAssigned Tocproensa 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.0 
Target VersionFixed in Version 
Summary0022588: Oversize upload is now skipped with no Message prompted
Description

Attempted to upload file with size larger than maximum size upon both the "Report issue" and "Issue Detail - add note" UI. Both behaved the same and just skip the upload section with no message prompted.
The warning message would only be shown when Mouse over the oversize attachment.

TagsNo tags attached.

Relationships

related to 0021801 closedcproensa File attachment GUI allows larger files than permitted 
related to 0025464 closedcproensa Enforce max-filesize in dropzone to alert and drop big files before form submission 
related to 0003759 confirmed Duplicate bug is created when resubmitting after file upload failure 

Activities

icoams

icoams

2017-04-03 02:40

reporter   ~0056334

Hi, any update?

Chris_Z

Chris_Z

2017-04-03 05:39

reporter   ~0056341

Unfortunately there are some nasty side-effects as well, see: 0021801 - it will sabotage e-mail notifications.

icoams

icoams

2017-04-03 06:11

reporter   ~0056342

Thanks for the reply. Is it possible to just make the error message always visible instead of only when the mouse is hovering over the oversized attachment?

icoams

icoams

2017-04-24 02:18

reporter   ~0056684

Hi, any update?

atrol

atrol

2017-04-24 17:42

developer   ~0056698

The warning message would only be shown when Mouse over the oversize attachment.

I don't get the message. This seems to be caused by CSP violations.

icoams

icoams

2017-04-24 21:45

reporter   ~0056700

When I drop an oversized file to the 'Upload Files', there is no message telling me that the file is oversized unless I hover the mouse over the file.

So unless user move the mouse over the oversized file, they have no way to know that the file is oversized:

  1. When they add type something in the 'Note' field then click 'Add Note', the note is successfully added but the file cannot be found anywhere in the issue.
  2. When they click 'Add Note' without typing anything in the 'Note' field, the user is redirected to an error page saying 'A necessary field "Note" was empty. Please recheck your inputs.'


no error message.png (16,451 bytes)
no error message.png (16,451 bytes)
atrol

atrol

2017-04-25 02:42

developer   ~0056701

@syncguru I didn't have a deeper look, but some of the known issues around file upload might be upstream bugs.
Not sure if going on to use dropzone is the right way as it seems to be quite dead
https://github.com/enyo/dropzone/graphs/contributors
with lots of open issues
https://github.com/enyo/dropzone/issues

icoams

icoams

2017-05-07 21:49

reporter   ~0056801

Hi, any update?

icoams

icoams

2017-05-14 21:44

reporter   ~0056852

Hi, any update?

icoams

icoams

2017-05-21 21:50

reporter   ~0056931

Hi, any update?

dregad

dregad

2017-05-22 03:40

developer   ~0056936

@icoams your weekly bumps are not going to help in getting this fixed. If this issue is important to you, I suggest you propose a pull request instead.

cproensa

cproensa

2019-03-05 16:48

developer   ~0061636

Resolving this, as related to 0025464

thE_iNviNciblE

thE_iNviNciblE

2019-03-10 06:24

reporter   ~0061656

:-)

Issue History

Date Modified Username Field Change
2017-03-27 02:41 icoams New Issue
2017-04-03 02:40 icoams Note Added: 0056334
2017-04-03 05:39 Chris_Z Note Added: 0056341
2017-04-03 06:11 icoams Note Added: 0056342
2017-04-24 02:18 icoams Note Added: 0056684
2017-04-24 17:31 atrol Relationship added related to 0021801
2017-04-24 17:36 atrol Status new => acknowledged
2017-04-24 17:42 atrol Note Added: 0056698
2017-04-24 21:45 icoams File Added: no error message.png
2017-04-24 21:45 icoams File Added: error message when mouse is hovering over file.png
2017-04-24 21:45 icoams Note Added: 0056700
2017-04-25 02:42 atrol Note Added: 0056701
2017-05-07 21:49 icoams Note Added: 0056801
2017-05-14 21:44 icoams Note Added: 0056852
2017-05-21 21:50 icoams Note Added: 0056931
2017-05-22 03:40 dregad Note Added: 0056936
2019-03-05 16:47 cproensa Relationship added related to 0025464
2019-03-05 16:47 cproensa Relationship added related to 0003759
2019-03-05 16:48 cproensa Note Added: 0061636
2019-03-05 16:48 cproensa Assigned To => cproensa
2019-03-05 16:48 cproensa Status acknowledged => resolved
2019-03-05 16:48 cproensa Resolution open => fixed
2019-03-10 06:24 thE_iNviNciblE Note Added: 0061656
2019-03-16 20:21 vboctor Status resolved => closed