View Issue Details

IDProjectCategoryView StatusLast Update
0023160mantisbtfilterspublic2019-08-20 21:37
Reporterjasonrumney Assigned Tocproensa  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0023160: [Feature request] Option to filter custom text fields based on being non-blank
Description

I have some custom fields in my local installation, which are filled with references to external documents for tracking purposes. Some issues will have this reference, but others will be left blank (mostly depending on who is filing the report, and whether they are running a specific set of test cases for testing against that document)

It is useful to be able to filter all bugs that have such references. This is the opposite of the "[none]" filter, and can be done quite tediously by switching to Advanced Filters, and selecting all options except "[any]" and "[none]", provided that list does not get truncated. But if that filter is saved, it is a snapshot of the values that were available at the time of saving, and any new references that are added later are not included in the filter.

Steps To Reproduce
  1. Add a custom text field.
  2. Fill a few different values on a few bugs
  3. Try to find all the bugs that have something filled in in the custom text field.
TagsNo tags attached.

Relationships

duplicate of 0012798 new Add a filter option [Something] as opposite of [None] i.e. field not null 
related to 0007693 new Need alternative filtering for custom fields 
related to 0007007 closedatrol Filter for custom field is lacking [empty] 

Activities

cproensa

cproensa

2019-08-20 21:37

developer   ~0062622

closed as duplicate of 0012798

Issue History

Date Modified Username Field Change
2017-07-26 01:27 jasonrumney New Issue
2017-07-27 14:35 atrol Relationship added related to 0007693
2017-07-27 14:38 atrol Relationship added related to 0007007
2019-08-20 21:37 cproensa Relationship added duplicate of 0012798
2019-08-20 21:37 cproensa Assigned To => cproensa
2019-08-20 21:37 cproensa Status new => resolved
2019-08-20 21:37 cproensa Resolution open => duplicate
2019-08-20 21:37 cproensa Note Added: 0062622
2019-08-20 21:37 cproensa Status resolved => closed