View Issue Details

IDProjectCategoryView StatusLast Update
0023378mantisbtinstallationpublic2020-08-17 05:08
Reporteratrol Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0023378: Installation fails when using old but still allowed PHP version 5.3

There are users in forum reporting problems when trying to install MantisBT 2.6.0.

One root cause seems to be using outdated PHP versions.

e.g. users get

[18-Sep-2017 09:37:18 UTC] PHP Parse error: syntax error, unexpected '[' in ../mantisbt26/vendor/guzzlehttp/psr7/src/functions.php on line 78

because array syntax introduced in PHP 5.4 is used.

function stream_for($resource = '', array $options = [])

At the moment we check for PHP minimum version 5.3.2, but have documented in Admin Guide to use at least 5.5.

Guzzle itself tells to use at least 5.5.x

This issue is not to reintroduce PHP 5.3 support but to enforce usage of PHP >= 5.5.0.

TagsNo tags attached.


related to 0025956 assigneddregad Increase minimum PHP requirement to 7.0 
related to 0023381 closedatrol Unneeded code for unsupported PHP versions 
related to 0024128 closedatrol Unable to start system check or installation with wrong PHP version 


Related Changesets

MantisBT: master 380fde11

2017-09-20 05:36:27


Details Diff
Enforce usage of PHP >= 5.5.0

Fixes 0023378
Affected Issues
mod - core/php_api.php Diff File