View Issue Details

IDProjectCategoryView StatusLast Update
0025956mantisbtinstallationpublic2019-08-25 16:42
Reporterdregad Assigned To 
Status newResolutionopen 
Product Version2.0.0 
Target Version2.23.0 
Summary0025956: Increase minimum PHP requirement to 7.0

Since MantisBT 2.0.0 we officially support PHP 5.5.9 and later, aligned with Ubuntu14.04 LTS "Trusty Tahr" release (as per discussion in 0021841).

PHP 5.5 is EOL since 21 Jul 2016, and PHP 5.6 support ended 31 Dec 2018 so I think it's finally time to put 5.x behind us.

Continuing our strategy to align requirements with Ubuntu LTS releases, the oldest one as of this writing is 16.04 Xenial Xerus, which comes bundled with PHP 7.0 by default. Note: 7.0 is also EOL since 31 Dec 2018.

Additional Information

Maintaining compatibility with PHP 5.x is becoming increasingly difficult, as more and more libraries and tools are dropping support for it (e.g. PHPUnit, and many others).

Travis CI is defaulting to Xenial for builds since May 2019 [1], and PHP 5.5 is not available at all under this distribution (see #25955). We can force use of Trusty for now to keep things working, but we need to make the switch at some point.

TagsNo tags attached.


related to 0021841 closeddregad mantisbt Minimum requirements for 2.x releases 
related to 0024128 closedatrol mantisbt Unable to start system check or installation with wrong PHP version 




2019-08-03 09:45

developer   ~0062498

I'm ok with this.



2019-08-03 10:14

developer   ~0062499

I am also ok with this when speaking about my own installations.

But keep in mind that I introduced a hard check for minimum PHP version in version 2.13.0 to fix 0024128.
So upgrading from 2.x 2.20.0 would stop some (maybe even quite a lot) of installations.

The general problem is, that we don't offer some kind of LTS version.



2019-08-03 11:05

developer   ~0062500

keep in mind that I introduced a hard check for minimum PHP version

Well if we require a minimum version, then I think it's normal that the software should fail with a message when the requirement is not met.

Even if technically, MantisBT would still work with older PHP versions, we can always instruct users who get stuck because they can't upgrade PHP on their server for whatever reason, to try - at their own risk of course - to change value of PHP_MIN_VERSION in their config.



2019-08-03 11:43

developer   ~0062501

to change value of PHP_MIN_VERSION in their config

Not possible at the moment. The check is done before config_inc.php is included. There was a good reason to check it in a very early state.
See also discussion on the PR



2019-08-25 16:42

manager   ~0062655

I always assumed that 2.0.0 we had PHP 7 as the target version, and support for PHP 5.x was best effort. Given that all 5.x are out of support, I think we should make PHP 7 a hard requirement and move on.

Issue History

Date Modified Username Field Change
2019-08-03 08:29 dregad New Issue
2019-08-03 08:31 dregad Relationship added related to 0021841
2019-08-03 09:45 cproensa Note Added: 0062498
2019-08-03 10:06 atrol Relationship added related to 0024128
2019-08-03 10:14 atrol Note Added: 0062499
2019-08-03 11:05 dregad Note Added: 0062500
2019-08-03 11:43 atrol Note Added: 0062501
2019-08-25 13:02 vboctor Target Version 2.22.0 => 2.23.0
2019-08-25 16:42 vboctor Note Added: 0062655