View Issue Details

IDProjectCategoryView StatusLast Update
0023909mantisbtadministrationpublic2018-02-07 02:55
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.10.0 
Target VersionFixed in Version2.12.0 
Summary0023909: User realname uniqueness check doesn't work
Description

Duplicate realnames are not rejected when creating or updating users.

TagsNo tags attached.

Relationships

has duplicate 0004226 closedvboctor Provide a way to disambiguate duplicate realnames 
related to 0023900 closedvboctor Unable to update user access level, due to check on 'Realname' returning KO (APPLICATION ERROR #807) 

Activities

vboctor

vboctor

2018-01-30 01:42

manager   ~0058667

PR: https://github.com/mantisbt/mantisbt/pull/1277

vboctor

vboctor

2018-02-04 03:32

manager   ~0058733

Closing as won't fix since we have decided to allow duplicate real names as per the following PR:
PR: https://github.com/mantisbt/mantisbt/pull/1277

Related Changesets

MantisBT: master cf5baefa

2018-01-30 01:34:28

vboctor

Details Diff
Fix username and realname uniqueness checks

- Fix user realname uniqueness check which wasn’t working.
- Remove `$g_differentiate_duplicates` config option.
- Change username realname uniqueness check APIs to not take in username, since these are independent operations.

Fixes 0023909, 0023900
Affected Issues
0023900, 0023909
mod - account_update.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/obsolete.php Diff File
mod - core/user_api.php Diff File
mod - manage_user_update.php Diff File

Issue History

Date Modified Username Field Change
2018-01-30 01:39 vboctor New Issue
2018-01-30 01:39 vboctor Status new => assigned
2018-01-30 01:39 vboctor Assigned To => vboctor
2018-01-30 01:42 vboctor Note Added: 0058667
2018-01-30 01:42 vboctor Relationship added related to 0023900
2018-01-30 02:21 vboctor Relationship added has duplicate 0004226
2018-02-04 03:32 vboctor Status assigned => resolved
2018-02-04 03:32 vboctor Resolution open => won't fix
2018-02-04 03:32 vboctor Note Added: 0058733
2018-02-04 03:32 vboctor Target Version 2.11.0 =>
2018-02-06 21:17 vboctor Status resolved => closed
2018-02-07 02:55 vboctor Changeset attached => MantisBT master cf5baefa
2018-02-07 02:55 vboctor Resolution won't fix => fixed
2018-02-07 02:55 vboctor Fixed in Version => 2.12.0