View Issue Details

IDProjectCategoryView StatusLast Update
0004226mantisbtuipublic2018-03-06 00:26
Reporterthraxisp Assigned Tovboctor  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Product Versiongit trunk 
Target Version2.12.0Fixed in Version2.12.0 
Summary0004226: Provide a way to disambiguate duplicate realnames
Description

Two realnames can be the same. There is no easy way to differentiate them.

Additional Information

The patch checked in for 0003975 has additional code to check for duplicates and set a flag in the user's database entry to allow them to be displayed differently. It is controlled by the config variable "differentiate_duplicates".

We need to consider how this works with LDAP before a final commit.

TagsNo tags attached.

Relationships

duplicate of 0023909 closedvboctor User realname uniqueness check doesn't work 
related to 0010493 closedvboctor Non-existent duplicate_realname column is updated by various functions in user_api.php 
related to 0024069 closedvboctor Show realname not working 

Activities

grangeway

grangeway

2007-07-21 09:46

reporter   ~0015127

Glenn,

Can this be resolved?

Paul

thraxisp

thraxisp

2007-07-22 10:29

reporter   ~0015153

It's still open. The code is in place, but not active. We need to create a database upgrade to populate the database properly.

vboctor

vboctor

2007-09-11 09:38

manager   ~0015609

Is this still an issue? I've recently fixed 0008343 which may be related to this issue.

thraxisp

thraxisp

2007-09-11 23:26

reporter   ~0015617

It's still open. The feature is to allow us to differentiate users with the same real name, but different user names. They are displayed as "John Doe(jdoe)" and "John Doe(sneezy)".

The installer needs code to find all duplicate usernames and set a flag in the database. Should I add this for 1.1?

vboctor

vboctor

2007-09-11 23:43

manager   ~0015618

Why set a flag? Why don't we change the duplicate names to have the user name and update the code to stop any future duplicate names. This will avoid extra overhead in constructing list of user names. And in the future will keep user names shorter.

I think we should aim to have the union of user names and user real names have no duplicates.

If we go with this fix, then we can include it in 1.1.0rc1.

thraxisp

thraxisp

2007-09-12 07:03

reporter   ~0015620

We can't do this. This would imply that the second "John Doe" to sign up can't use their real name. I agree that usernames should be unique, but real names don't have to be. The real name can also match the user name for an individual.

Adding the flag eliminates any overhead as the flag is in the same query as the username/real name.

grangeway

grangeway

2008-07-28 16:14

reporter   ~0018862

Glenn? :)

Paul

thraxisp

thraxisp

2009-05-19 21:27

reporter   ~0021846

All that is required to complete this is to add the database update:

$upgrade[] = Array( 'AddColumnSQL', Array( db_get_table( 'mantis_user_table' ), "
duplicate_realname I UNSIGNED NOTNULL DEFAULT '0' " ) );

I would do this except someone commented out the rest of the related code.

vboctor

vboctor

2018-01-30 02:19

manager   ~0058670

The uniqueness is enforced via:
https://github.com/mantisbt/mantisbt/pull/1277

vboctor

vboctor

2018-02-04 03:36

manager   ~0058734

The following PR was revised to allow duplicate real names or real names that are duplicate with a username:
https://github.com/mantisbt/mantisbt/pull/1277

To disambiguate duplicates, usernames are now displayed as:

  • usernames with a bubble for realname.
  • realname (username)

The code was refactored to always use central APIs for printing and sorting of user names. The sorting respects the configuration option to sort by last name when enabled.

Issue History

Date Modified Username Field Change
2004-07-30 16:16 thraxisp New Issue
2007-07-21 09:46 grangeway Note Added: 0015127
2007-07-22 10:29 thraxisp Note Added: 0015153
2007-09-11 09:38 vboctor Note Added: 0015609
2007-09-11 09:38 vboctor Status new => feedback
2007-09-11 23:26 thraxisp Note Added: 0015617
2007-09-11 23:43 vboctor Note Added: 0015618
2007-09-12 07:03 thraxisp Note Added: 0015620
2008-07-28 16:14 grangeway Note Added: 0018862
2008-07-28 16:14 grangeway Status feedback => assigned
2008-07-28 16:14 grangeway Assigned To => thraxisp
2009-05-19 21:13 thraxisp Relationship added related to 0010493
2009-05-19 21:27 thraxisp Note Added: 0021846
2009-05-19 21:27 thraxisp Assigned To thraxisp =>
2009-05-19 21:27 thraxisp Status assigned => confirmed
2018-01-30 02:19 vboctor Assigned To => vboctor
2018-01-30 02:19 vboctor Status confirmed => assigned
2018-01-30 02:19 vboctor Target Version => 2.11.0
2018-01-30 02:19 vboctor Note Added: 0058670
2018-01-30 02:21 vboctor Status assigned => resolved
2018-01-30 02:21 vboctor Resolution open => duplicate
2018-01-30 02:21 vboctor Relationship added duplicate of 0023909
2018-02-04 03:36 vboctor Status resolved => assigned
2018-02-04 03:36 vboctor Resolution duplicate => open
2018-02-04 03:36 vboctor Note Added: 0058734
2018-02-04 03:36 vboctor Summary Non-unique realnames aren't flagged => Provide a way to disambiguate duplicate realnames
2018-02-04 03:43 vboctor Category bugtracker => ui
2018-02-06 21:22 vboctor Target Version 2.11.0 => 2.12.0
2018-02-07 02:50 vboctor Status assigned => resolved
2018-02-07 02:50 vboctor Resolution open => duplicate
2018-02-07 02:50 vboctor Fixed in Version => 2.12.0
2018-03-04 00:36 vboctor Status resolved => closed
2018-03-06 00:26 vboctor Relationship added related to 0024069