View Issue Details

IDProjectCategoryView StatusLast Update
0024174mantisbtcode cleanuppublic2018-04-29 19:21
ReporteroreolekAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.12.0 
Target Version2.14.0Fixed in Version2.14.0 
Summary0024174: E_DEPRECATED error on php7.2: each() function
Description

After upgrade to PHP 7.2 there's this message on every page:

DEPRECATED: 'The each() function is deprecated. This message will be suppressed on further calls' in '[mantispath]/vendor/adodb/adodb-php/adodb.inc.php' line 1167

TagsNo tags attached.

Relationships

related to 0023640 closedatrol Usage of deprecated each() function 
related to 0024192 closeddregad Update ADOdb to 5.20.12 

Activities

atrol

atrol

2018-03-27 07:26

developer   ~0059321

A fix is available in master branch of ADOdb but not yet available in an official release
https://github.com/ADOdb/ADOdb/pull/373

atrol

atrol

2018-03-30 06:07

developer   ~0059360

Fixed in ADOdb v5.20.11 https://github.com/ADOdb/ADOdb/releases
But we have to wait for v5.20.12 because of

Do not use with PHP 5.x : the fix for # 405 will only work with PHP 7.x. A backwards-compatible version will be released soon.

dregad

dregad

2018-03-30 15:45

developer   ~0059370

I just released ADOdb 5.20.12. Will open an issue and prepare a PR for the update.

dregad

dregad

2018-03-30 16:08

developer   ~0059372

PR https://github.com/mantisbt/mantisbt/pull/1323

Related Changesets

MantisBT: master fd9b9b3c

2018-03-30 15:53:26

dregad


Committer: vboctor Details Diff
Update ADODb library to 5.20.12

Composer update:
- Updating adodb/adodb-php (v5.20.9 => v5.20.12)

Fixes 0024192, 0024174
Affected Issues
0024174, 0024192
mod - composer.lock Diff File

Issue History

Date Modified Username Field Change
2018-03-27 07:18 oreolek New Issue
2018-03-27 07:26 atrol Status new => confirmed
2018-03-27 07:26 atrol Note Added: 0059321
2018-03-27 07:29 atrol Relationship added related to 0023640
2018-03-30 06:07 atrol Note Added: 0059360
2018-03-30 15:45 dregad Note Added: 0059370
2018-03-30 15:52 dregad Relationship added related to 0024192
2018-03-30 16:08 dregad Note Added: 0059372
2018-03-31 20:07 vboctor Changeset attached => MantisBT master fd9b9b3c
2018-03-31 20:07 dregad Assigned To => dregad
2018-03-31 20:07 dregad Status confirmed => resolved
2018-03-31 20:07 dregad Resolution open => fixed
2018-03-31 20:07 dregad Fixed in Version => 2.14.0
2018-04-01 03:52 atrol Target Version => 2.14.0
2018-04-29 19:21 vboctor Status resolved => closed