View Issue Details

IDProjectCategoryView StatusLast Update
0024602Plugin - ReminderGeneralpublic2019-07-15 07:21
ReporterP3t3r Assigned Tocas  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0024602: Reminder plugin
Description

Hi,

We are currently using MantisBT 2.15 and the latest version of the Reminder plugin 2.05, but it won't work unfortunately.
I'm getting an SQL error when i run the assigned_bugs.php via an Windows BATCH file.

It won't update the issues with an note and no messages were send by email.

Additional Information

APPLICATION ERROR 0000401: Database query failed. Error received from database was #1054: Unknown column 'mantis_bug_table.project_id' in 'where clause' for the query: SELECT DISTINCT b.id bug_id, b.summary, b.handler_id, u.realname, u.email
FROM mantis_bug_table b JOIN mantis_user_table u ON (b.handler_id = u.id) WHERE
status < ? and mantis_bug_table.project_id NOT IN (0).

config_inc.php:
$g_phpMailer_method = PHPMAILER_METHOD_SMTP is used for sending email

PHP version 7.1

TagsNo tags attached.

Activities

P3t3r

P3t3r

2018-07-11 09:29

reporter  

screenshot.PNG (53,302 bytes)   
screenshot.PNG (53,302 bytes)   
cas

cas

2018-07-11 09:43

manager   ~0060246

Is this a fresh install?
I am running 2.16 and no issues

P3t3r

P3t3r

2018-07-11 12:20

reporter   ~0060250

Yes

P3t3r

P3t3r

2018-07-11 12:23

reporter   ~0060251

I have just uninstall the plug-in, downloaded the latest version of GitHub and keeping the same database error when I run assigned_bugs.php file via the batch file.

P3t3r

P3t3r

2018-07-18 08:20

reporter   ~0060277

Hi Cas,

Hope you can / want to assist me with this because i'm really excited about the plug-in.

Peter

cas

cas

2018-07-18 15:10

manager   ~0060280

Peter,
can you test with the following script:
Reminder\scripts\bug_reminder_mail_test.php
You can rubn this directly in the browser.
Please post results here

cas

cas

2018-08-29 08:32

manager   ~0060525

Please install version 2.06 in which issue has been resolved.

rcfloresh

rcfloresh

2018-10-12 16:37

reporter   ~0060799

Where is the 2.06 version?? is in github??

cas

cas

2018-10-13 03:53

manager   ~0060800

Go with 2.13:
https://mantisbt.org/bugs/view.php?id=24706#c60582

Issue History

Date Modified Username Field Change
2018-07-11 09:29 P3t3r New Issue
2018-07-11 09:29 P3t3r File Added: screenshot.PNG
2018-07-11 09:43 cas Note Added: 0060246
2018-07-11 12:20 P3t3r Note Added: 0060250
2018-07-11 12:23 P3t3r Note Added: 0060251
2018-07-18 08:20 P3t3r Note Added: 0060277
2018-07-18 15:10 cas Note Added: 0060280
2018-08-29 08:32 cas Note Added: 0060525
2018-08-29 08:32 cas Assigned To => cas
2018-08-29 08:32 cas Status new => resolved
2018-08-29 08:32 cas Resolution open => fixed
2018-10-12 16:37 rcfloresh Note Added: 0060799
2018-10-13 03:53 cas Note Added: 0060800