View Issue Details

IDProjectCategoryView StatusLast Update
0025716mantisbtcustomizationpublic2019-05-06 16:16
Reportermegamanus Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2.21.0 
Summary0025716: Feature request: Option to customize My View page
Description

Hi!

Developers and reporters pay attention to the issues they are interested in, but mostly these may be a very different set.

  • Developers like to see the new issues and the ones that are assigned to him/her.
  • Reporters like to see the issues that they reported or that they are monitoring.
    Also the content of some boxes (for example timeline) may not be interesting for some users.

So I have a request to create an option in "My Account" settings for all users to change the order of boxes or completly hide them (unassigned, resolved, reported_by_me, recently_modified, monitored_by_me, timeline etc.) on the "My View" page.

This can be solved for each user like the customization of order of fileds.

Thanks!

TagsNo tags attached.

Relationships

duplicate of 0007840 acknowledged Customizable 'my view' page 

Activities

megamanus

megamanus

2019-04-25 06:29

reporter   ~0061990

I talked with another user (developer) of the same mantis installation and he said that he has different layout:

Assigned | Reported by me
Unassigned | Resolved
Recently Modified | Monitored by Me

while mine (reporter) is:

Unassigned | Resolved
Recently Modified | Monitored by Me
Reported by Me

Maybe the admin set this, but an option for reordering by the user would be welcome...

Maurycy

Maurycy

2019-04-25 06:33

reporter   ~0061991

There is configuration option my_view_boxes (see: https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.myview) and you can set it per user, but unfortunately there is no option to set by User type. I would love that option myself.

atrol

atrol

2019-04-25 06:36

developer   ~0061992

Last edited: 2019-04-25 06:38

View 2 revisions

The original request to have the setting in user preferences is covered by duplicate 0007840.

@megamanus there is also an automatism. That's the reason why a reporter does not get the "Assigned to me" box, but developers get it.

megamanus

megamanus

2019-04-25 06:47

reporter   ~0061993

Last edited: 2019-04-25 06:48

View 2 revisions

@atrol
I know that reporters can't have "assigned" issues, it was just an example to show that the orders are different (regardless of this), that means it is stored for groups/users... and so be different...
As the age of the original request and its many duplicates indicate the issue is important for a lot of uses.

Thanks for the link of original request!

atrol

atrol

2019-04-25 10:20

developer   ~0061994

@megamanus not sure if you understood what @Maurycy told at 0025716:0061991
If this is important for you and if you need it now, it can be done (but not by using a nice end user UI) by setting option my_view_boxes in database https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.intro

@Maurycy maybe intersting for you 0006480:0033235

Issue History

Date Modified Username Field Change
2019-04-25 06:13 megamanus New Issue
2019-04-25 06:29 megamanus Note Added: 0061990
2019-04-25 06:33 Maurycy Note Added: 0061991
2019-04-25 06:36 atrol Assigned To => atrol
2019-04-25 06:36 atrol Status new => resolved
2019-04-25 06:36 atrol Resolution open => duplicate
2019-04-25 06:36 atrol Note Added: 0061992
2019-04-25 06:36 atrol Relationship added duplicate of 0007840
2019-04-25 06:38 atrol Note Edited: 0061992 View Revisions
2019-04-25 06:47 megamanus Note Added: 0061993
2019-04-25 06:48 megamanus Note Edited: 0061993 View Revisions
2019-04-25 10:20 atrol Note Added: 0061994
2019-05-06 16:16 atrol Status resolved => closed