View Issue Details

IDProjectCategoryView StatusLast Update
0026781mantisbtbugtrackerpublic2020-04-06 05:53
Reporteramphetamine Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.24.0 
Target Version2.24.1Fixed in Version2.24.1 
Summary0026781: changed project order / sequence
Description

2.23 and older, project order by alphabetical

2.24 project order by date created

how to reverse that?

TagsNo tags attached.

Relationships

has duplicate 0026786 closedatrol In top-right drop-down menu, Projects are no more in alpha order since update from 2.23 to 2.24 
has duplicate 0026848 resolvedatrol Project list is sorted by id for Admins 

Activities

dregad

dregad

2020-03-16 04:20

developer   ~0063762

On what screen did you notice this behavior change ?

amphetamine

amphetamine

2020-03-16 04:33

reporter   ~0063763

both show_project_menu_bar & drop down project menu

atrol

atrol

2020-03-16 06:11

developer   ~0063764

Last edited: 2020-03-16 12:32

View 2 revisions

@dregad I am able to reproduce the issue on my local test install.
Reverting MantisBT master 2a42ea38 fixes the issue.

dregad

dregad

2020-03-16 12:31

developer   ~0063769

I must have had some caching issue, because I did not notice this in my tests, but I can also confirm the behavior now. Will revert the offending commit.

Related Changesets

MantisBT: master 2a42ea38

2020-03-09 08:17:30

dregad

Details Diff
Remove unnecessary ORDER_BY clause Affected Issues
0026781
mod - core/project_hierarchy_api.php Diff File

MantisBT: master-2.24 82f22737

2020-03-16 12:30:12

dregad

Details Diff
Revert "Remove unnecessary ORDER_BY clause"

This reverts commit 2a42ea38e8bf073d8932f0a0c62034357c8883db.

Turns out the ORDER BY was necessary after all...

Fixes 0026781
Affected Issues
0026781
mod - core/project_hierarchy_api.php Diff File

Issue History

Date Modified Username Field Change
2020-03-15 23:37 amphetamine New Issue
2020-03-16 04:20 dregad Status new => feedback
2020-03-16 04:20 dregad Note Added: 0063762
2020-03-16 04:33 amphetamine Note Added: 0063763
2020-03-16 04:33 amphetamine Status feedback => new
2020-03-16 06:11 atrol Status new => confirmed
2020-03-16 06:11 atrol Note Added: 0063764
2020-03-16 12:31 dregad Assigned To => dregad
2020-03-16 12:31 dregad Status confirmed => assigned
2020-03-16 12:31 dregad Note Added: 0063769
2020-03-16 12:32 dregad Target Version => 2.24.1
2020-03-16 12:32 dregad Note Edited: 0063764 View Revisions
2020-03-16 12:32 dregad Changeset attached => MantisBT master 2a42ea38
2020-03-16 12:32 dregad Changeset removed MantisBT master 2a42ea38 =>
2020-03-16 12:32 dregad Changeset attached => MantisBT master 2a42ea38
2020-03-16 12:35 dregad Changeset attached => MantisBT master-2.24 82f22737
2020-03-16 12:35 dregad Status assigned => resolved
2020-03-16 12:35 dregad Resolution open => fixed
2020-03-16 12:36 dregad Fixed in Version => 2.24.1
2020-03-16 14:10 atrol Relationship added has duplicate 0026786
2020-04-06 05:53 atrol Relationship added has duplicate 0026848