View Issue Details

IDProjectCategoryView StatusLast Update
0003864mantisbtcustom fieldspublic2011-12-23 06:16
Reporterkarath Assigned Tograngeway  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Summary0003864: Provide facility to report Custom Fields
Description

1 - add the list of Custom Fields to print_all_bug_options_page.php
2 - output the selected list of custom fields in print_all_bug_page_excel.php and print_all_bug_page_wod.php

Additional Information

Requirements issues to be left to the developers to decide on.

1 - Should the list of Custom Fields be
a - all of the Custom Fields available in the installation(simplest to implement, so probably my recommended option),
b - all of the Custom Fields available to any of the selected projects or
c - only those Custom Fields available to all of the selected projects.
Users can currently select "All Projects" or a specific project, but I understand that there is a feature request to allow users to select multiple projects.

2 - Restrictions on which users can view which Custom Fields.

3 - Inevitably, if this feature is implemented, there will be requests to filter and sort on custom fields. If I could get the facility to report Custom Fields to Excel, I would be happy to do the sorting and filtering there.

TagsNo tags attached.

Relationships

related to 0003994 closedvboctor Custom Fields on "View Bugs" page and Exported to Excel 
child of 0004937 closedvboctor Mantis 1.0.0a1 Release 

Activities

matt_doran

matt_doran

2004-07-13 23:25

reporter   ~0006032

I agree that exporting custom fields using the reports is a key feature. Without it custom fields are much less useful.

I am using custom fields to track things like 'Client Name' and 'Time spent' against support issues. But without being able to export these fields, it hardly makes it worth using them.

You can't get the data out without manually viewing each issue one at a time.

haaseg

haaseg

2004-08-17 14:37

reporter   ~0007034

Last edited: 2004-08-17 14:37

According to the roadmap for 19.0 http://www.mantisbt.org/roadmap.php the ability to filter on custom fields is done (point 3 in Additional Information).

I too am in need of the ability to export custom fields, and would prefer option b. (list all custom fields for all selected projects); however beggers can't be choosers and option c. is acceptible. Although option a. is noted as simplest to implement, I think it is also the least flexible of the 3 (although one could argue that it's relatively simple to delete columns from the export).

edited on: 08-17-04 14:37

2004-08-22 16:06

 

csv_api.php.diff (547 bytes)   
80c80,93
< 
---
> 	
> 	function csv_get_custom_columns() {
> 		# first get the custom columns for this project
> 			$t_project_id	=	helper_get_current_project();
> 
> 			$t_custom_columns = array();
> 			$t_related_custom_field_ids = custom_field_get_linked_ids( $t_project_id );
> 			foreach( $t_related_custom_field_ids as $t_id ) {
> 				$t_def = custom_field_get_definition( $t_id );
> 				$t_custom_columns[$t_id] = $t_def['name'];
> 				//echo custom_field_get_value( $t_id, $v_id );
> 			}
> 		return $t_custom_columns;
> 	}
csv_api.php.diff (547 bytes)   

2004-08-22 16:07

 

csv_export.php.diff (347 bytes)   
47c47,48
< 
---
> 	$t_custom_columns = csv_get_custom_columns();
> 	
53c54,57
< 
---
> 	foreach ($t_custom_columns as $c_column => $c_title ) {
> 		$t_titles[] = $c_title;
> 	}
> 	
80c84,86
< 
---
> 		foreach ( $t_custom_columns as $cust_key => $cust_title ) {
> 			$t_values[] = custom_field_get_value( $cust_key, $row['id'] );
> 		}
csv_export.php.diff (347 bytes)   
haaseg

haaseg

2004-08-22 16:11

reporter   ~0007100

It got to a point where I absolutely needed to export some custom fields with the CSV, so I spent a couple hours at it and got a very basic implementation. It only works if you have a single project selected, and it exports ALL the custom fields associated with that project.

I attached two diff files, but it's the first time I've done a diff, so please let me know if they don't work for some reason.

mcain

mcain

2004-10-10 20:46

reporter   ~0007978

This is the missing feature my users complain about. Is it a likely inclusion in the next version?

Matt_wc

Matt_wc

2004-10-17 23:12

reporter   ~0008089

I am in the same boat here.

We have several custom fields that we consider important enough that they should be included in both reporting, and view_bugs pages.

Can this be included for the 19.1 release?

Matt_wc

Matt_wc

2004-10-17 23:29

reporter   ~0008091

Tested the Diff files and it worked for me (version 18.3 on Windows)

Thanks haaseg for the files =)

eurayle

eurayle

2005-06-08 12:08

reporter   ~0010427

Is the patch in 0003315 going to be incorporated into the future release of Mantis? The patch was written for an older version of Mantis, so when I tried to apply it onto v1.0.0a3, it was quite difficult, since some codes have changed since then. That issue is closed and why is Fixed in Release value set to 1.0.0a3?

fxm

fxm

2009-05-11 03:56

reporter   ~0021800

Is this functionnality implemented in last version (1.1.7) ? The question is always "Is there a possibility to export custom fields ?".

Thansk for your comment.

rombert

rombert

2011-12-11 17:40

reporter   ~0030550

This functionality is available with MantisBT 1.2.x .

Issue History

Date Modified Username Field Change
2004-05-20 01:23 karath New Issue
2004-07-13 23:25 matt_doran Note Added: 0006032
2004-08-08 16:40 grangeway Relationship added related to 0003994
2004-08-08 16:40 grangeway Status new => acknowledged
2004-08-17 14:37 haaseg Note Added: 0007034
2004-08-17 14:37 haaseg Note Edited: 0007034
2004-08-22 16:06 haaseg File Added: csv_api.php.diff
2004-08-22 16:07 haaseg File Added: csv_export.php.diff
2004-08-22 16:11 haaseg Note Added: 0007100
2004-08-23 12:40 grangeway Assigned To => grangeway
2004-10-10 20:46 mcain Note Added: 0007978
2004-10-17 23:12 Matt_wc Note Added: 0008089
2004-10-17 23:13 Matt_wc Sponsorship Added Matt_wc: US$ 5
2004-10-17 23:13 Matt_wc Sponsorship Total 0 => 5
2004-10-17 23:29 Matt_wc Note Added: 0008091
2004-12-01 03:26 jlatour Relationship added child of 0004818
2004-12-04 19:33 vboctor Relationship added child of 0004937
2004-12-04 19:34 vboctor Relationship deleted child of 0004818
2004-12-22 15:37 jlatour Relationship deleted child of 0004937
2004-12-22 15:44 jlatour Relationship added child of 0005038
2004-12-22 15:48 jlatour Relationship deleted child of 0005038
2004-12-22 15:49 jlatour Relationship added child of 0004937
2005-06-08 12:08 eurayle Note Added: 0010427
2009-05-11 03:56 fxm Note Added: 0021800
2011-12-11 17:40 rombert Note Added: 0030550
2011-12-11 17:40 rombert Status acknowledged => resolved
2011-12-11 17:40 rombert Resolution open => no change required
2011-12-23 06:16 atrol Status resolved => closed