View Issue Details

IDProjectCategoryView StatusLast Update
0004937mantisbtbugtrackerpublic2005-04-25 07:52
Reportervboctor Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version1.0.0a1 
Summary0004937: Mantis 1.0.0a1 Release
Description

This is a parent issue for all the issues that need to be fixed for 1.0.0a1

TagsNo tags attached.

Relationships

related to 0004818 closedvboctor Mantis 0.19.2 release 
parent of 0004609 closedgrangeway 'one-off' Temporary Filters should store state in Database 
parent of 0004551 closedbpfennig Sticky issues 
parent of 0004315 closedthraxisp Show filter without reloading whole page 
parent of 0004929 closedthraxisp Inscriptions on the graphs on Apache for Microsoft Windows for CP1251 do not hatch. 
parent of 0004959 closedbpfennig "Delete Issue" should show information identifying issue to be deleted 
parent of 0004664 closedmasc Can't upload project documents for "All Projects" 
parent of 0004952 closedthraxisp some issues with script authentication support 
parent of 0004960 closedthraxisp Show parameter name in gpc_api.php error messages 
parent of 0004962 closedbpfennig URL not parsing after ? in any link 
parent of 0004964 closedbpfennig Backdoor for assigning sponsored issues 
parent of 0004966 closedgrangeway DHTML filters do not load if another filter is clicked simultaneously 
parent of 0004967 closedthraxisp DHTML filter loading does not handle advanced filters effectively 
parent of 0004971 closedthraxisp Bargraphs show lines - this is incorrect 
parent of 0004976 closedthraxisp Relationship section uses the language of the person who did the action 
parent of 0004981 closeddregad Problems with performance when upgrading to v 19 
parent of 0004973 closedgrangeway website changelog prints error message 
parent of 0004979 closedbpfennig Images not shown while printing bug details 
parent of 0004978 closedthraxisp g_notify_flags + reopened and owner 
parent of 0004987 closeddregad Added export functionality into other Mantis instance 
parent of 0004982 closedbpfennig Mantis fails converting nested URLs into hyperlinks 
parent of 0004984 closedthraxisp Resolution and SolvedInVersion fields are necessary for Changelog, Summary and Graphs, but they are optional. 
parent of 0004986 closedthraxisp Graphs should cache data 
parent of 0004983 closedthraxisp HTML should not be allowed in the Summary field, even if it is part of the allowed HTML list in the configuration 
parent of 0004994 closedbpfennig Two "system font directories" in configuration 
parent of 0004993 acknowledged Utility to copy attachments from File to Database 
parent of 0004992 closedthraxisp Use of is_uploaded_file() in file_add() prevents use in importer PHP script. 
parent of 0004996 closedthraxisp "Open and assigned to me" shows wrong number 
parent of 0004314 closedbpfennig Bug status percentage 
parent of 0004998 closedthraxisp Can't use Date Filters in the filters screens 
parent of 0004999 closedgrangeway "Add Note" link should open the note form if it is currently collapsed 
parent of 0005003 closedthraxisp unserialize() can be unsafe to use in PHP 
parent of 0005000 closedvboctor String custom field type isnt big enough - need multiline string option 
parent of 0005006 closed phpMailer - SMTP Error: Could not authenticate 
parent of 0005010 acknowledged Being able to give the status "public" or private to the uploaded files 
parent of 0005013 closedvboctor html_status_percentage_legend() generates notices 
parent of 0005016 closedgrangeway meta-refresh required 
parent of 0005022 closedvboctor user-names must not contain dots [.] 
parent of 0005023 closedWanderer Typo in french localization - "bug courrant" should be "bug courant" 
parent of 0005015 closedgrangeway Upload screenshots/screen captures and clipboard images 
parent of 0005029 closedthraxisp Queries and timings are not shown in login page 
parent of 0003864 closedgrangeway Provide facility to report Custom Fields 
parent of 0005031 closedWanderer Typos in Norwegian translation 
parent of 0004787 closedthraxisp Issue Summary is marked as updated when it contains 'quotes' or "double quotes" 
parent of 0005399 closedthraxisp DHTML filters doesn't manage special characters 
parent of 0005319 closedWanderer Syntax error in strings_japanese_sjis.txt on line 1085 
parent of 0005305 closedthraxisp My View | Click Category Header Link | Next Page - You don't get the proper page 2. 
parent of 0005255 closed When I Complete sign in form I Got Error 
parent of 0005040 acknowledged non-required custom field zero length validation 
parent of 0004589 closedthraxisp Administrator cannot manage projects to which he/she is assigned. 
parent of 0005416 closedthraxisp mandatory custom field: problem when updating an "Display when Reporting Issues" only bug 
parent of 0004853 closedthraxisp Add the ability to filter by relationship 
parent of 0005113 closedthraxisp include duplicate-of and has-duplicate relationship options when creating a clone 
parent of 0005434 closedvboctor More SELECT DISTINCT (in filter_api.php) 
parent of 0005438 closedthraxisp *_bug_threshold set to an array in the new DB based configuration 
parent of 0005445 closedthraxisp You can delete the last administrator in the system. 
related to 0004278 new Summary email vs detailed email 
related to 0004438 closeddregad My View: Different appearance 
related to 0004784 closedatrol Clicking the validation link in an email at Hotmail causes App Error #-12 
related to 0005247 closedthraxisp Real email addresses are visible when using reminders 
related to 0005210 closedthraxisp Manager of one Project can see / manage all others 
related to 0005460 closedvboctor Critical Issues to Fix for Mantis 1.0.0 Release 
Not all the children of this issue are yet resolved or closed.

Activities

bpfennig

bpfennig

2004-12-15 17:13

reporter   ~0008642

What about this for 0.19.3?

0004314

anarcat

anarcat

2005-02-05 00:07

reporter   ~0009218

Last edited: 2005-02-05 00:12

How about bug 3045 for this release?

InterWiki markup! Wouldn't you love to see Wiki markup in Mantis?? That would rock. :)

I spent some time to work up a patch, and it seems to be working well, even though the bug isn't marked as resolved.

What do you guys thing?

andri

andri

2005-02-07 13:42

reporter   ~0009232

how about http://bugs.mantisbt.org/view.php?id=5175 ? I've included a patch so this could be a simple apply.

stevemagruder

stevemagruder

2005-02-08 23:33

reporter   ~0009265

Since new features are going in, might this really be 0.20.0? Just a thought. At any rate, I'm very excited about the next release. Great job, guys!

Matt_wc

Matt_wc

2005-02-09 20:14

reporter   ~0009276

Please look at 0005113 as it's a good and very quick fix.

mgerben

mgerben

2005-02-11 06:13

reporter   ~0009286

I very much like this trick you guys use to create a parent issue for all bugs to be solved in a particular version.
It can help a lot when the number of issues is large.

My question: Do you think it is possible to make direct links from a project to generate overviews of which versions are going to solve which bugs, and very importantly, which bugs do not have a 'solved in version' value assigned yet?
In addition to this, a developers workload could be altered to show only the bugs he's supposed to work on for the current version, or at least to sort the list by 'solved in version'.

thraxisp

thraxisp

2005-02-11 10:04

reporter   ~0009289

If you look at this another way, we already have this feature. In my implementation, the policy is to set the "fixed in version" when the issue is assigned. The normal sorting or filtering process can then be used to generate lists related to the release. The changelog will list those items that have been resolved thus far.

mgerben

mgerben

2005-02-14 04:21

reporter   ~0009305

Thraxis,

How is this done? Is it done automatically or manually? We have to set it manually and the person who assigns it might not know in which version it's going to be solved. Or he might simply forget to assign a value to this field.
I think there's some room for reports here. Care to email me directly? I don't want to polute this issue any more than I have done already.
mgerben@yahoo.com

johnwebbcole

johnwebbcole

2005-02-15 12:47

reporter   ~0009326

Could 0004853 be considered for the 0.19.3 release? It shouldn't need too much more work, and has no schema changes. Patches are inlcuded for the current CVS head. It makes working with issues like this one (a task list issue) a lot easier, and allows you to export an issue with relationships to excel for PHB's.

Thanks,

John

vboctor

vboctor

2005-04-18 10:47

manager   ~0009831

The release was cut on 18-04-2005.

Issue History

Date Modified Username Field Change
2004-12-04 19:31 vboctor New Issue
2004-12-04 19:32 vboctor Relationship added related to 0004818
2004-12-04 19:33 vboctor Relationship added parent of 0003864
2004-12-04 19:35 vboctor Relationship added parent of 0004609
2004-12-05 04:00 vboctor Relationship added parent of 0004551
2004-12-05 04:02 vboctor Relationship added parent of 0004278
2004-12-05 04:03 vboctor Relationship added parent of 0004787
2004-12-05 04:16 vboctor Relationship added parent of 0004438
2004-12-05 04:17 vboctor Relationship added parent of 0004315
2004-12-05 04:19 vboctor Status new => confirmed
2004-12-05 04:19 vboctor Relationship added parent of 0004634
2004-12-07 16:55 jlatour Relationship added parent of 0004784
2004-12-07 16:57 jlatour Relationship deleted parent of 0004634
2004-12-07 16:59 jlatour Relationship added parent of 0004929
2004-12-09 11:05 jlatour Relationship added parent of 0004564
2004-12-09 11:22 jlatour Relationship added parent of 0004959
2004-12-09 11:27 jlatour Relationship added parent of 0004664
2004-12-09 11:29 jlatour Relationship added parent of 0004952
2004-12-09 14:09 jlatour Relationship added parent of 0004887
2004-12-09 14:17 jlatour Relationship added parent of 0004960
2004-12-09 15:11 jlatour Relationship added parent of 0004220
2004-12-10 01:35 jlatour Relationship added parent of 0004961
2004-12-10 01:36 jlatour Relationship added parent of 0004957
2004-12-11 07:35 jlatour Relationship added parent of 0004962
2004-12-12 14:00 jlatour Relationship added parent of 0004964
2004-12-13 16:44 jlatour Relationship added parent of 0004966
2004-12-13 16:45 jlatour Relationship added parent of 0004967
2004-12-13 16:46 jlatour Relationship added parent of 0004971
2004-12-14 00:37 jlatour Relationship added parent of 0004977
2004-12-14 00:48 jlatour Relationship added parent of 0004976
2004-12-15 01:55 jlatour Relationship added parent of 0004981
2004-12-15 01:57 jlatour Relationship added parent of 0004973
2004-12-15 01:57 jlatour Relationship added parent of 0004979
2004-12-15 01:58 jlatour Relationship added parent of 0004978
2004-12-15 17:13 bpfennig Note Added: 0008642
2004-12-16 08:41 jlatour Relationship added parent of 0004987
2004-12-16 08:43 jlatour Relationship added parent of 0004982
2004-12-16 08:45 jlatour Relationship added parent of 0004984
2004-12-16 08:47 jlatour Relationship added parent of 0004986
2004-12-16 09:00 jlatour Relationship added parent of 0004983
2004-12-16 17:20 jlatour Relationship added parent of 0004994
2004-12-16 17:26 jlatour Relationship added parent of 0004993
2004-12-16 17:28 jlatour Relationship added parent of 0004992
2004-12-17 04:17 jlatour Relationship added parent of 0004996
2004-12-17 04:24 jlatour Relationship added parent of 0004314
2004-12-17 09:04 thraxisp Relationship added parent of 0004998
2004-12-17 09:39 jlatour Relationship added parent of 0004999
2004-12-17 12:20 jlatour Relationship added parent of 0005003
2004-12-17 12:20 jlatour Relationship added parent of 0005000
2004-12-17 14:03 jlatour Relationship added parent of 0005006
2004-12-18 01:55 jlatour Relationship added parent of 0005010
2004-12-18 06:24 vboctor Relationship added parent of 0005013
2004-12-19 18:21 jlatour Relationship added parent of 0005016
2004-12-20 17:28 jlatour Relationship added parent of 0005022
2004-12-20 17:29 jlatour Relationship added parent of 0005023
2004-12-20 17:32 jlatour Relationship added parent of 0005015
2004-12-21 15:54 jlatour Relationship added parent of 0005029
2004-12-22 15:36 jlatour Relationship added related to 0005038
2004-12-22 15:37 jlatour Relationship deleted parent of 0003864
2004-12-22 15:49 jlatour Relationship added parent of 0003864
2004-12-22 15:50 jlatour Relationship added parent of 0005031
2004-12-22 15:54 jlatour Relationship deleted parent of 0004278
2004-12-22 15:57 jlatour Relationship deleted parent of 0004787
2004-12-22 16:01 jlatour Relationship deleted parent of 0004438
2004-12-22 16:04 jlatour Relationship deleted parent of 0004784
2004-12-22 20:29 thraxisp Relationship added parent of 0004787
2004-12-23 11:07 thraxisp Relationship deleted parent of 0004977
2005-02-05 00:07 anarcat Note Added: 0009218
2005-02-05 00:08 anarcat Note Edited: 0009218
2005-02-05 00:09 anarcat Note Edited: 0009218
2005-02-05 00:12 anarcat Note Edited: 0009218
2005-02-07 13:42 andri Note Added: 0009232
2005-02-08 23:33 stevemagruder Note Added: 0009265
2005-02-09 20:14 Matt_wc Note Added: 0009276
2005-02-11 06:13 mgerben Note Added: 0009286
2005-02-11 10:04 thraxisp Note Added: 0009289
2005-02-14 04:21 mgerben Note Added: 0009305
2005-02-15 12:47 johnwebbcole Note Added: 0009326
2005-03-01 17:30 grangeway Relationship added related to 0004278
2005-03-01 17:31 grangeway Relationship added related to 0004438
2005-03-01 17:34 grangeway Relationship added related to 0004784
2005-03-01 17:40 grangeway Relationship deleted related to 0005038
2005-04-04 18:17 jlatour Summary Mantis 0.19.3 Release => Mantis 1.0.0a1 Release
2005-04-04 18:22 jlatour Description Updated
2005-04-04 19:03 thraxisp Relationship added parent of 0005399
2005-04-05 13:15 thraxisp Relationship added parent of 0005319
2005-04-05 16:45 thraxisp Relationship added parent of 0005305
2005-04-05 16:47 thraxisp Relationship added parent of 0005255
2005-04-05 18:56 thraxisp Relationship added related to 0005247
2005-04-05 19:42 thraxisp Relationship added related to 0005210
2005-04-05 19:54 thraxisp Relationship added parent of 0005040
2005-04-05 20:13 thraxisp Relationship added parent of 0004578
2005-04-05 21:39 thraxisp Relationship deleted parent of 0004887
2005-04-05 21:40 thraxisp Relationship deleted parent of 0004961
2005-04-05 21:41 thraxisp Relationship deleted parent of 0004957
2005-04-07 08:13 thraxisp Relationship added parent of 0004589
2005-04-09 08:11 thraxisp Relationship added parent of 0005416
2005-04-10 10:56 thraxisp Relationship added parent of 0004853
2005-04-10 10:59 thraxisp Relationship added parent of 0005113
2005-04-14 18:10 vboctor Relationship added parent of 0005434
2005-04-15 18:08 thraxisp Relationship added parent of 0005438
2005-04-17 13:13 thraxisp Relationship added parent of 0005445
2005-04-18 10:47 vboctor Status confirmed => resolved
2005-04-18 10:47 vboctor Fixed in Version => 1.0.0a1
2005-04-18 10:47 vboctor Resolution open => fixed
2005-04-18 10:47 vboctor Assigned To => vboctor
2005-04-18 10:47 vboctor Note Added: 0009831
2005-04-20 07:44 vboctor Relationship added related to 0005460
2005-04-22 15:16 grangeway Relationship deleted parent of 0004564
2005-04-22 15:19 grangeway Relationship deleted parent of 0004220
2005-04-22 19:53 thraxisp Relationship deleted parent of 0004578
2005-04-25 07:52 vboctor Status resolved => closed