View Issue Details

IDProjectCategoryView StatusLast Update
0009793mantisbtjavascriptpublic2014-12-08 00:34
Reporterswekey Assigned Todhx  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformall 
Product Version1.2.0a2 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0009793: ActiveXObject emulation hack should be removed
Description

xmlhttprequest.js contains a nasty hack to emulate IE activex support:

// ActiveXObject emulation
if (!window.ActiveXObject && window.XMLHttpRequest) {
window.ActiveXObject = function(type) {
switch (type.toLowerCase()) {
case 'microsoft.xmlhttp':
case 'msxml2.xmlhttp':
return new XMLHttpRequest();
}
return null;
};
}

That's very bad since plugins can no longer rely on 'window.ActiveXObject' to check for activex support in the current browser.

This method is widely used when we try to embed a browser plugin (Flash Player for instance) to check of the browser should load the activex or the mozilla plugin.

TagsNo tags attached.

Relationships

duplicate of 0012631 closeddhx Replace old inline dynamic filter code with jQuery equivalent 
related to 0011826 closeddhx Remove all inline JavaScript from MantisBT (use external scripts instead) 
related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

vboctor

vboctor

2008-11-12 17:30

manager   ~0019860

Do you have a proposed patch?

dhx

dhx

2010-09-19 03:21

reporter   ~0026785

I can't believe the term "ActiveX" is contained within the MantisBT source. It's a disgrace and needs to be removed at once. Queued for 1.3.x :)

dhx

dhx

2010-12-26 07:57

reporter   ~0027701

Removed today as part of the fix for 0012631.

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036314

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Issue History

Date Modified Username Field Change
2008-11-10 03:50 swekey New Issue
2008-11-12 17:30 vboctor Note Added: 0019860
2010-09-19 03:20 dhx Relationship added related to 0011826
2010-09-19 03:20 dhx Status new => confirmed
2010-09-19 03:21 dhx Note Added: 0026785
2010-09-19 03:21 dhx Target Version => 1.3.0-beta.1
2010-12-26 07:57 dhx Note Added: 0027701
2010-12-26 07:57 dhx Relationship added duplicate of 0012631
2010-12-26 07:57 dhx Status confirmed => resolved
2010-12-26 07:57 dhx Resolution open => duplicate
2010-12-26 07:57 dhx Assigned To => dhx
2011-08-05 02:52 atrol Fixed in Version => 1.3.0-beta.1
2012-03-04 02:08 vboctor Status resolved => closed
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036314
2013-04-05 18:24 grangeway Relationship added related to 0015721
2013-04-06 03:44 dregad Status acknowledged => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed