View Issue Details

IDProjectCategoryView StatusLast Update
0001353mantisbtemailpublic2002-01-09 10:26
Reporterepu Assigned Toupdater  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0001353: Mantis sends HTML in text-only emails
Description

Email arrives with HTML tags, but email is not recognized as HTML document. Tags appear inline in the document, making an illegible email.

Additional Information

Mantis needs to either strip HTML tags from outgoing email or create email of an HTML type so that tags display as HTML in user's clients.

TagsNo tags attached.

Relationships

related to 0001400 assignedvboctor Feature to send HTML-formatted e-mail instead of text e-mail 
related to 0001401 new Request option to strip HTML from text-only e-mail 

Activities

reporter

reporter

2002-01-08 12:09

reporter   ~0001761

If you implement HTML email I think it would be best if it was an option (HTML or Plain Text).

I haven't found the HTML tags to be annoying.
You could simply request that users don't input them bypassing the problem.

rufinus

rufinus

2002-01-09 04:55

reporter   ~0001765

@epu: and what is when you use mantis for debuging webprojects, and the reporter posts html code to fix a problem ? :) Thats the reason, where the strip_tags function is not used in the email functions, instead mantis use some str_replace() commands.

epu

epu

2002-01-09 10:18

reporter   ~0001774

Ah, I figured that was what attachments were for (posting code). Our business does not do any development besides Mantis in PHP or HTML so I hadn't thought of that.

Suggest adding following features as separate feature requests and closing this bug;

  • option to send HTML-formatted e-mail instead of text e-mail.
  • option to display HTML inline with syntax colors in HTML-formatted email.
  • option to strip HTML from text-only e-mail

edited on: 01-09 10:35

Issue History

Date Modified Username Field Change
2006-03-09 13:02 ryandesign Relationship added related to 0001400
2007-01-24 16:22 DGtlRift Relationship added related to 0001401