View Issue Details

IDProjectCategoryView StatusLast Update
0001401mantisbtemailpublic2018-01-31 06:59
Reporterepu Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status newResolutionopen 
Summary0001401: Request option to strip HTML from text-only e-mail
Description

Admins can allow users to post using HTML tags, but e-mail is always sent as unformatted text with HTML displayed in-line. This in-line code can make e-mail illegible.

To make text-only e-mail legible, give users the ability to enable/disable stripping of HTML from their e-mail body when e-mail is sent as type "Content: Text" or no content type is given.

Additional Information

Related to bug 0001353.

TagsNo tags attached.

Relationships

related to 0001353 closedupdater Mantis sends HTML in text-only emails 
related to 0001400 assignedvboctor Feature to send HTML-formatted e-mail instead of text e-mail 
has duplicate 0009416 closedatrol Plaintext e-mails should have HTML tags stripped 

Activities

atrol

atrol

2013-01-02 13:19

developer   ~0034673

Reopend as I resolved the wrong (older) one.

lbayle2

lbayle2

2018-01-29 12:19

reporter   ~0058663

Has something changed recently, HTML emails used to work.
I think this is more than a nice to have as it breaks the "forgot your password" link in the email

this patch worked for me.
https://www.mantisbt.org/forums/viewtopic.php?f=4&t=3786

atrol

atrol

2018-01-29 13:16

developer   ~0058665

this patch worked for me.

This patch enables HTML email.

The current issue is a different thing, it's

option to strip HTML from text-only e-mail

lbayle2

lbayle2

2018-01-31 06:04

reporter   ~0058694

Last edited: 2018-01-31 06:59

View 2 revisions

Here below the email content.

  • HTML is in plain text
  • the URL contains "&" instead of "&" which breaks the link

I got the problem when I upgraded from mantis 2.2.1 to 2.6.0 (using same config files, same plugins)
but most surprisingly, when I rolled back to v2.2.1 the problem was still there !
So I searched for any configuration concerning email in the mantis_config_table but could not find anything that could have changed.

To make it work again, I had to hard-code "$t_mail->IsHTML( true );" in core/email_api.php

So I'm realy puzzeled, because how could it work before if HTML is disabled in the code ?
It can only be some configuration issue (as rollback did not work) but where ?

Someone (presumably you) requested a password change through e-mail verification. If this was not you, ignore this message and nothing will happen.<br /> <br /> If you requested this verification, visit the following URL to change your
password: <br />
<br />
https://my_fake_server.net/prjmngt/mantis/verify.php?id=2&confirm_hash=A8D6015EJZtAvfip601Q0ujFRawJY3U9zbHYsQ8aqCXUbmmcr_vvFy6HMDht0PzxddEKBORRcp57y76Fd8Cw
<br />
<br />
Username: lbayle <br />
Remote IP address: 172.23.138.66 <br />
<br />
Do not reply to this message
lbayle2

lbayle2

2018-01-31 06:07

reporter   ~0058695

In my previous message, Mantis seems to have processed the "plain-text HTML" as real HTML, so the sample text is useless.
Nevertheless, you probably understand what I meant

dregad

dregad

2018-01-31 06:59

developer   ~0058696

In my previous message, Mantis seems to have processed the "plain-text HTML" as real HTML, so the sample text is useless.

I quoted the text so the HTML tags are not rendered.

Issue History

Date Modified Username Field Change
2007-01-24 16:22 DGtlRift Relationship added related to 0001353
2007-01-24 16:24 DGtlRift Relationship added related to 0001400
2013-01-02 13:17 atrol Relationship added duplicate of 0009416
2013-01-02 13:17 atrol Status new => resolved
2013-01-02 13:17 atrol Resolution open => duplicate
2013-01-02 13:17 atrol Assigned To => atrol
2013-01-02 13:19 atrol Note Added: 0034673
2013-01-02 13:19 atrol Assigned To atrol =>
2013-01-02 13:19 atrol Status resolved => new
2013-01-02 13:19 atrol Relationship replaced has duplicate 0009416
2016-07-07 02:39 atrol Resolution duplicate => open
2018-01-29 12:19 lbayle2 Note Added: 0058663
2018-01-29 13:16 atrol Note Added: 0058665
2018-01-31 06:04 lbayle2 Note Added: 0058694
2018-01-31 06:07 lbayle2 Note Added: 0058695
2018-01-31 06:59 dregad Note Edited: 0058694 View Revisions
2018-01-31 06:59 dregad Note Added: 0058696