View Issue Details

IDProjectCategoryView StatusLast Update
0022688mantisbtuipublic2019-07-11 15:29
ReporterTiKu Assigned Toatrol  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Product Version2.3.0 
Summary0022688: Menu items not clickable if plugins add too many of them
Description

I use a plugin that adds 6 buttons to the menu on the left side. On some older laptops the display resolution is too low so that not all menu buttons are visible. Collapsing the menu would help, but the button to collapse it isn't visible as well. Currently the only solution is to zoom out until all buttons are visible.
It would be great if Mantis could handle such a situation a bit better. I agree that a scrollable menu probably would be quite ugly, but maybe the collapse button could be turned into a sticky button that won't be moved out of the visible screen. For me this already would be sufficient.

TagsNo tags attached.

Relationships

duplicate of 0025893 new BAD displaying for several plugin MAIN Menu button 
has duplicate 0023361 closedatrol No Sidebar vertical overflow 
has duplicate 0024730 closedatrol Left sidebar elements are not visible if a lot of elements have to be displayed 

Activities

dregad

dregad

2017-04-07 03:44

developer   ~0056431

It may be helpful to provide us with a link to the plugin you're using, as it would facilitate problem reproduction.

I don't know if that's an option, but as a workaround, you may want to consider changing the plugin so that it uses a sub-menu approach (similar to the Manage page) instead of adding so many top-level items.

TiKu

TiKu

2017-04-07 04:49

reporter   ~0056434

The plugin is an internal one of my company. I cannot make it public that easy. But I can provide a sample plugin that just adds enough menu items to reproduce the problem. Shall I?

Sub-menus already are used to some degree, but the plugin is a huge one and there are plenty of pages that cannot really be grouped logically underneath the same main menu item.

atrol

atrol

2019-06-28 04:46

developer   ~0062332

Setting the older issue as resolved, as there is a user offering a pull request in the newer one 0025893

dregad

dregad

2019-06-28 05:20

developer   ~0062334

as there is a user offering a pull request in the newer one 0025893

@atrol, I don't see any PR related to this , and definitely no mention of it in 0025893. Maybe you confused with 0025892 ?

If there is indeed no PR, then I'd suggest to reopen this one and close 0025893 as duplicate.

atrol

atrol

2019-06-28 05:52

developer   ~0062337

@dregad I used wrong wording

The user does not offer a PR but asks if we would agree to a PR, see description of 0025893

Would you agree to a possible pull request ?

Issue History

Date Modified Username Field Change
2017-04-06 14:11 TiKu New Issue
2017-04-07 03:44 dregad Note Added: 0056431
2017-04-07 04:49 TiKu Note Added: 0056434
2017-09-15 02:15 atrol Relationship added has duplicate 0023361
2018-09-03 10:41 atrol Relationship added has duplicate 0024730
2019-06-28 04:46 atrol Assigned To => atrol
2019-06-28 04:46 atrol Status new => resolved
2019-06-28 04:46 atrol Resolution open => duplicate
2019-06-28 04:46 atrol Note Added: 0062332
2019-06-28 04:46 atrol Relationship added duplicate of 0025893
2019-06-28 05:20 dregad Note Added: 0062334
2019-06-28 05:52 atrol Note Added: 0062337
2019-07-11 15:29 atrol Status resolved => closed