View Issue Details

IDProjectCategoryView StatusLast Update
0024087mantisbtfeaturepublic2018-03-31 19:58
ReportersbordoniAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.12.0 
Target VersionFixed in Version 
Summary0024087: $g_show_realname problem on 2.12.0
Description

I have set '$g_show_realname' to ON in my config file.

After the upgrade to v2.12.0 it doesn't work anymore (ie the assign bug .

In v2.11.1, it was working fine.

TagsNo tags attached.

Relationships

related to 0024069 closedvboctor Show realname not working 
related to 0024090 closedvboctor Username (Realnames) format not showing on timeline (my_view_page) 
related to 0024139 closedatrol $g_show_realname for making usernames private 

Activities

atrol

atrol

2018-03-08 05:36

developer   ~0059117

Have you set $g_show_user_realname_threshold ?

sbordoni

sbordoni

2018-03-09 04:28

reporter   ~0059132

I tried to uncomment the $g_show_user_realname_threshold in my config file... and it didn't work.

I looked for some documentation into MBT Admin Guide, but I didn't find anything.

Surfing on the web, I found a page that suggest to set it as below:

<pre>$g_show_user_realname_threshold = ANYBODY;</pre>

This solved my problem.

I suppose that this new param should replace '$g_show_realname'.

Is there any documentation about this param?

atrol

atrol

2018-03-09 04:45

developer   ~0059133

I suppose that this new param

It's not new, but used a little bit different in earlier versions.

Is there any documentation about this param?

Not in Admin Guide at the moment, but in config_defaults_inc.php

@vboctor again I am asking myself if it's not better to obsolete show_realname.
If not, we might consider changing default setting of show_user_realname_threshold to avoid regressions.

alopezserrano

alopezserrano

2018-03-09 05:24

reporter   ~0059134

Same problem for me.

I have this configuration and doesn't work...

#$g_show_realname = ON;
$g_show_user_realname_threshold = ANYBODY;

Help please!!

atrol

atrol

2018-03-09 05:33

developer   ~0059135

@alopezserrano
you have to uncomment the line

$g_show_realname = ON;
alopezserrano

alopezserrano

2018-03-09 05:42

reporter   ~0059136

Gracias!

oricgn

oricgn

2018-03-09 08:49

reporter   ~0059140

Same problem to me. I just updated to 2.12.0. Real names not shown any longer.

My config.inc.php:

$g_show_realname           = ON;
$g_show_user_realname_threshold = ANYBODY;
Ruzhelovich Vladimir

Ruzhelovich Vladimir

2018-03-10 12:21

reporter   ~0059151

The problem is actual to me too.

atrol

atrol

2018-03-10 12:29

developer   ~0059152

The problem is actual to me too.

Isn't it fixed by setting the option?

$g_show_user_realname_threshold = ANYBODY;
Ruzhelovich Vladimir

Ruzhelovich Vladimir

2018-03-10 13:26

reporter   ~0059153

No, It Isn't fixed.

my config_inc.php too:
$g_show_realname = ON;
$g_show_user_realname_threshold = ANYBODY;

On version 2.11.1 is no problem

atrol

atrol

2018-03-10 13:57

developer   ~0059154

No, It Isn't fixed.

Depends on what you mean with fixed.
At least at the moment you shouldn't expect to get exactly what you had before.

Maybe this explains the confusion 0024069:0059091

it will appear as a bubble if you hover over the username

Ruzhelovich Vladimir

Ruzhelovich Vladimir

2018-03-10 21:57

reporter   ~0059162

Thank you. I understud

I commented in 0024069:0059161

vboctor

vboctor

2018-03-21 03:10

manager   ~0059254

@atrol We could deprecate $g_show_realname and rely on the fact that $g_show_user_realname_threshold was defaulted to NOBODY. Feel free to open a specific issue for this.

I suggest resolving this issue as no change required.

atrol

atrol

2018-03-21 12:44

developer   ~0059267

Last edited: 2018-03-21 12:45

View 3 revisions

@vboctor, just to be sure that we are talking about the same thing.

When I asked for obsoleting $g_show_realname, I thought that there is some redundant logic, as
$g_show_realname = OFF == $g_show_user_realname_threshold = NOBODY and
$g_show_realname = ON == $g_show_user_realname_threshold = any value >= VIEWER

I didn't mean that we remove any existing functionality.

There are some aspects to consider

Security

Visibility of the real name is driven by option $g_show_user_realname_threshold
This option was independant from $g_show_realname before version 2.12

I am not sure why $g_show_user_realname_threshold has been introduced.
It's first purpose was just to hide the real name from view_user_page.
Do we need this option?
I can't answer it, as I didn't introduce the option and I don't need it myself.

You could argue, that

  • a user who does not want that his real name is known to the public shouldn't enter the real name.
  • a user who enters his real name does not know at this moment, that it's not visible to any other user.
    so the option could be removed

You could argue, that

  • the administrator of a Mantis installation does not want that any user can see real names
    but, should this be the decision of the Mantis administrator?
    If so, the option can not be removed

Functionality / backward compatibility

Why does someone set real_names to ON?
Because he wants to see the real names!
After the changes in 2.12, real names are no longer visible at some places, at least not at first sight.

So maybe displaying the real name and having the user name as the bubble is the better approach.
The only disadvantage I see at the moment, is that @ mentions are not that easy.

What about replacing $g_show_realname by something like $g_display_user_format ?

#define ( 'USERNAME', 0 );
#define ( 'REALNAME', 1 );
#define ( 'USERNAME_REALNAME', 2 );
#define ( 'REALNAME_USERNAME', 3 );

$g_display_user_format = USERNAME;
  • USERNAME display user name, no real name
  • REALNAME display real name, display user name if real name is not set or access is not allowed
  • USERNAME_REALNAME display user name, real name as bubble or in brackets, if access is allowed
  • REALNAME_USERNAME display real name if set and access is allowed, display user name as bubble or in brackets. If not set or not allowed, display user name.
vboctor

vboctor

2018-03-23 20:04

manager   ~0059300

Visibility of the real name is driven by option $g_show_user_realname_threshold. This option was independant from $g_show_realname before version 2.12

I wouldn't be if different pages had different behaviors there, since such decision was done in so many places in the code. One of the core changes I have done, is centralized this decision and formatting of username across all scenarios. I missed timeline scenario which was fixed in 2.12.1 that should go out soon.

$g_show_user_realname_threshold vs $g_show_realname

The former is more powerful than the latter since it can allow showing realnames to DEVELOPER+ and only show username to users with lower access level. Hence, we could retire $g_show_realname and just keep $g_show_user_realname_threshold.

So maybe displaying the real name and having the user name as the bubble is the better approach.

That is easy to do now, since we do this functionality in one place. However, it doesn't handle the non-unique case in an obvious way, makes @ mentions harder, etc.

What about replacing $g_show_realname by something like $g_display_user_format ?

We could have a config options for preference to show realname vs. username. If user chooses realname, but logged in user doesn't have access to it, then fallback to username. That however causes complexity about sorting the list by usernames vs. realnames. So it is not just a display issue and requires more places in the code to understand this configuration option.

As for order of which ones display first in case of showing first, again we get into having the sort to take this into consideration, etc.

I think the current model is simpler and we should stick with it. I understand that some users get confused initially, but I suspect that once the behavior understood it makes sense. I think it may make sense to deprecate show_realname config option though.

atrol

atrol

2018-03-27 17:42

developer   ~0059328

I suggest resolving this issue as no change required.

Will do

I think it may make sense to deprecate show_realname config option though

Right, but let's see in 0024139 if we can deprecate or if we should replace by a format option.

Issue History

Date Modified Username Field Change
2018-03-08 05:22 sbordoni New Issue
2018-03-08 05:36 atrol Status new => feedback
2018-03-08 05:36 atrol Note Added: 0059117
2018-03-09 04:28 sbordoni Note Added: 0059132
2018-03-09 04:28 sbordoni Status feedback => new
2018-03-09 04:45 atrol Note Added: 0059133
2018-03-09 05:24 alopezserrano Note Added: 0059134
2018-03-09 05:33 atrol Note Added: 0059135
2018-03-09 05:42 alopezserrano Note Added: 0059136
2018-03-09 08:49 oricgn Note Added: 0059140
2018-03-09 10:27 atrol Relationship added related to 0024090
2018-03-10 12:21 Ruzhelovich Vladimir Note Added: 0059151
2018-03-10 12:29 atrol Note Added: 0059152
2018-03-10 12:45 atrol Relationship added related to 0024069
2018-03-10 13:26 Ruzhelovich Vladimir Note Added: 0059153
2018-03-10 13:57 atrol Note Added: 0059154
2018-03-10 21:57 Ruzhelovich Vladimir Note Added: 0059162
2018-03-20 03:42 atrol Relationship added related to 0024139
2018-03-21 03:10 vboctor Note Added: 0059254
2018-03-21 12:44 atrol Note Added: 0059267
2018-03-21 12:44 atrol Note Edited: 0059267 View Revisions
2018-03-21 12:45 atrol Note Edited: 0059267 View Revisions
2018-03-23 20:04 vboctor Note Added: 0059300
2018-03-27 17:42 atrol Note Added: 0059328
2018-03-27 17:42 atrol Assigned To => atrol
2018-03-27 17:42 atrol Status new => resolved
2018-03-27 17:42 atrol Resolution open => no change required
2018-03-31 19:58 vboctor Status resolved => closed