View Issue Details

IDProjectCategoryView StatusLast Update
0024069mantisbtuipublic2018-03-31 19:58
Reporterclan_destinaAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version2.12.0 
Target VersionFixed in Version 
Summary0024069: Show realname not working
Description

I updated my version from 2.11.1 to 2.12.0 and the "show real name" is not working.
I have defined the variables:
$g_show_realname = ON;
$g_show_user_realname_threshold = REPORTER;

The view page only shows usernames

TagsNo tags attached.

Relationships

related to 0004226 closedvboctor Provide a way to disambiguate duplicate realnames 
related to 0024090 closedvboctor Username (Realnames) format not showing on timeline (my_view_page) 
related to 0024087 closedatrol $g_show_realname problem on 2.12.0 
related to 0024139 closedatrol $g_show_realname for making usernames private 

Activities

vboctor

vboctor

2018-03-06 00:25

manager   ~0059091

Checkout 0004226 and 0023375 for more context about latest changes. Basically the behavior has changed to:

  • When displaying user name, if logged in user has access to view real name, it will appear as a bubble if you hover over the username.
  • For drop down user lists, show realname and username in the drop down.

This disambiguates duplicate realnames and makes it easy to @ mention users.

clan_destina

clan_destina

2018-03-06 07:36

reporter   ~0059096

Ok, some observation:

  • the timeline on my_view_page is showing realnames (contradict duplicate real name approach)
  • if accessed from a mobile device (cellphone or table) the hover over is not possible to view realname
vboctor

vboctor

2018-03-07 00:37

manager   ~0059099

the timeline on my_view_page is showing realnames (contradict duplicate real name approach)

Confirmed, please open a bug for this.

if accessed from a mobile device (cellphone or table) the hover over is not possible to view realname

The approach mobile experience would be to click on username and get to user page. Please open specific bugs for cases where this is not possible and we should fix them.

Ruzhelovich Vladimir

Ruzhelovich Vladimir

2018-03-10 21:54

reporter   ~0059161

I think that the previous function was more logical. Because it allows you to see a user's full name or username.

Not always possible to determine the login name of the user. At the moment to identify the user need to take additional actions, which of course is not convenient for users.

If possible, think about the additional configuration that would be displayed in the format of the realname.

dc_ao

dc_ao

2018-03-13 12:57

reporter   ~0059199

I think that the previous function was more logical. Because it allows you to see a user's full name or username.
+1

vboctor

vboctor

2018-03-21 03:02

manager   ~0059252

I'm closing this issue as no change required. Ruzhelovich Vladimir and @dc_ao feel free to open another issue with more specific behavior request.

Ruzhelovich Vladimir

Ruzhelovich Vladimir

2018-03-21 03:15

reporter   ~0059255

I'm closing this issue as no change required. Ruzhelovich Vladimir and @dc_ao feel free to open another issue with more specific behavior request.

Ok! :)

Issue History

Date Modified Username Field Change
2018-03-05 17:32 clan_destina New Issue
2018-03-06 00:25 vboctor Assigned To => vboctor
2018-03-06 00:25 vboctor Status new => feedback
2018-03-06 00:25 vboctor Note Added: 0059091
2018-03-06 00:25 vboctor Category other => ui
2018-03-06 00:26 vboctor Relationship added related to 0004226
2018-03-06 07:36 clan_destina Note Added: 0059096
2018-03-06 07:36 clan_destina Status feedback => assigned
2018-03-07 00:37 vboctor Note Added: 0059099
2018-03-10 12:43 atrol Relationship added related to 0024090
2018-03-10 12:45 atrol Relationship added related to 0024087
2018-03-10 21:54 Ruzhelovich Vladimir Note Added: 0059161
2018-03-13 12:57 dc_ao Note Added: 0059199
2018-03-20 03:43 atrol Relationship added related to 0024139
2018-03-21 03:02 vboctor Status assigned => resolved
2018-03-21 03:02 vboctor Resolution open => no change required
2018-03-21 03:02 vboctor Note Added: 0059252
2018-03-21 03:15 Ruzhelovich Vladimir Note Added: 0059255
2018-03-31 19:58 vboctor Status resolved => closed