View Issue Details

IDProjectCategoryView StatusLast Update
0007450mantisbtfeaturepublic2012-09-16 17:21
Reporterachumakov Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Summary0007450: Filing bugs on behalf of another user
Description

To make an efficient use of Mantis as a helpdesk with 1st line call centre, it could be helpful to let developer choose a 'Reporter' field manually (if actual reporter e.g. phones him/her).

The similar option exists in 'change issue' form, but it takes too more clicks to get there.

TagsNo tags attached.

Relationships

duplicate of 0011615 closeddregad Select reporter while adding an issue 
has duplicate 0006580 closedgiallu Bug reporting for developers 
has duplicate 0006185 closedgiallu How to assign a bug to another reporter 
has duplicate 0003125 closedgiallu managers/administrators need to be able to set reporter 

Activities

achumakov

achumakov

2006-09-17 08:28

reporter   ~0013406

Too much, i meant ;)

vboctor

vboctor

2006-09-20 00:11

manager   ~0013416

We should add this feature, but is should be controlled by a configuration option 'set_reporter_threshold' which is defaulted to NOBODY. When set to an access level it allows users with such access and above to specify a reporter name. The reporter name must always be default to the current logged in user. An issue must always have a valid reporter name.

achumakov

achumakov

2006-09-20 05:25

reporter   ~0013419

You said exactly what I meant ;-)

atrol

atrol

2012-09-04 15:50

developer   ~0032785

There is a plugin for MantisBT 1.2
https://github.com/mantisbt-plugins/CustomReporter

Closed the older issue as the newer one 0011615 contains some more information.

Issue History

Date Modified Username Field Change
2006-09-17 08:05 achumakov New Issue
2006-09-17 08:28 achumakov Note Added: 0013406
2006-09-20 00:11 vboctor Note Added: 0013416
2006-09-20 00:11 vboctor Status new => acknowledged
2006-09-20 05:25 achumakov Note Added: 0013419
2007-08-10 06:51 giallu Relationship added has duplicate 0006580
2007-08-10 06:56 giallu Relationship added has duplicate 0006185
2007-08-10 07:01 giallu Relationship added has duplicate 0003125
2012-09-04 15:50 atrol Note Added: 0032785
2012-09-04 15:50 atrol Relationship added duplicate of 0011615
2012-09-04 15:50 atrol Status acknowledged => resolved
2012-09-04 15:50 atrol Resolution open => duplicate
2012-09-04 15:50 atrol Assigned To => atrol
2012-09-16 17:21 atrol Status resolved => closed