View Issue Details

IDProjectCategoryView StatusLast Update
0009868mantisbtfilterspublic2017-07-31 15:27
Reportertmatijasevic Assigned Torombert  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
PlatformMantisOSNAOS VersionNA
Product Version1.1.4 
Target VersionFixed in Version 
Summary0009868: Added ability to search custom fields in version 1.1.4
Description

I posted this to ticket number 0006325 but this mantis system gave me an error when i tried to upload the files... So here is a new ticket to be attached to that ticket.

SEE ATTACHMENT AND TICKET 0006325

Steps To Reproduce

SEE ATTACHMENT AND TICKET 0006325

Additional Information

SEE ATTACHMENT AND TICKET 0006325

TagsNo tags attached.

Relationships

related to 0007183 acknowledged new search function on field and custom field 
has duplicate 0009790 closedgrangeway Possibility to add custom fields to the standard search field 

Activities

2008-11-25 18:12

 

filter_api_1.1.4SearchMod.zip (69,271 bytes)
tmatijas

tmatijas

2008-11-25 18:14

reporter   ~0020050

OK After several days the uploader is working again. I have attached the file to make custom feilds searchable in version 1.1.4... should prort easily to version 1.1.5 as well. Perhaps if I have time I will do this as well. Best, Tom

2009-01-04 13:33

 

jvizueta

jvizueta

2009-01-04 13:41

reporter   ~0020530

Tested on mantis 1.1.2 and 1.1.6, filter_api.php has only 3 lines different from 1.1.2 to 1.1.6, I think filter_api.php in 1.1.4 is the same as in 1.1.2, the problem is the same in both cases, when trying to filter by a custom field (no search involved) it throws an APPLICATION ERROR 0000401, something about a mysql query malformed, you can see error in attached file: error_401_thrown_when_filtering_by_custom_field(no search).jpg

jvizueta

jvizueta

2009-01-25 22:15

reporter   ~0020712

Any news on this? I think searching through custom fields is such an important feature, because first time users always take it for granted, users start to untrust on the search feature because it's not bringing information they know it's there and they don't know why this is happening (users can't tell which field is a core field and which one is a custom field, the only thing they know is that what they're looking for has got to be in a field value somewhere), this feature would make searching on Mantis more intuitive, I think it should be considered to be part of Mantis core

rombert

rombert

2012-09-01 14:20

reporter   ~0032759

This functionality is already part of MantisBT 1.2.x, so closing.

Issue History

Date Modified Username Field Change
2008-11-22 01:32 tmatijasevic New Issue
2008-11-25 18:12 tmatijas File Added: filter_api_1.1.4SearchMod.zip
2008-11-25 18:14 tmatijas Note Added: 0020050
2008-12-06 18:29 grangeway Relationship added has duplicate 0009790
2009-01-04 13:33 jvizueta File Added: error_401_thrown_when_filtering_by_custom_field(no search).jpg
2009-01-04 13:41 jvizueta Note Added: 0020530
2009-01-25 22:15 jvizueta Note Added: 0020712
2011-01-01 08:54 atrol Relationship added related to 0007183
2012-09-01 14:20 rombert Note Added: 0032759
2012-09-01 14:20 rombert Status new => resolved
2012-09-01 14:20 rombert Resolution open => no change required
2012-09-01 14:20 rombert Assigned To => rombert
2012-09-16 17:21 atrol Status resolved => closed