View Issue Details

IDProjectCategoryView StatusLast Update
0012667mantisbtbugtrackerpublic2011-09-16 11:03
ReportervboctorAssigned Tovboctor 
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.3 
Target Version1.2.5Fixed in Version1.2.5 
Summary0012667: Moving issues between projects doesn't update the category
Description

If an issue with category GUI is moved from Project A to Project B (where both have the category defined as non-global), then the issue will show the category name in the view page as "[Project A] GUI" even though the issue now belongs to project B. Also if the user edits the issue, the first category is selected from the list since "[Project A] GUI" is not a valid entry.

The proposed fix is as follows:

  1. If the category is global, then leave as is.
  2. If the category has a match by name in the target project, then switch to that.
  3. If the category doesn't have a match by name in the target project, then move a configured default global category (by default "General").
TagsNo tags attached.

Relationships

related to 0005034 closedvboctor On move project you can't specify the category you'd like to move to 
related to 0010325 confirmed Move should have the option of changing categories 
related to 0006763 closedvboctor when try to "move" an issue, only "project" can be changed, however, there is no way to update "category" 
has duplicate 0007518 closedvboctor Move issue with specified category to project without categories 
has duplicate 0004671 closedvboctor Problems with categories after issue move 
has duplicate 0009641 closedvboctor Categories dont get reassigned when moving issues 
has duplicate 0012896 closedatrol Issues are moved without updating the category-id 
related to 0013233 new Allow status change upon moving tickets to another project 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master-1.2.x a25d69fc

2011-01-07 20:55:31

vboctor

Details Diff
Fix 0012667: Moving issues between projects doesn't update the category

If an issue with category GUI is moved from Project A to Project B (where both have the category defined as non-global), then the issue will show the category name in the view page as "[Project A] GUI" even though the issue now belongs to project B. Also if the user edits the issue, the first category is selected from the list since "[Project A] GUI" is not a valid entry.

The proposed fix is as follows:

1. If the category is global, then leave as is.
2. If the category has a match by name in the target project, then switch to that.
3. If the category doesn't have a match by name in the target project, then move a configured default global category (by default "General").
Affected Issues
0012667
mod - bug_actiongroup.php Diff File
mod - docbook/adminguide/en/configuration.sgml Diff File
mod - config_defaults_inc.php Diff File
mod - core/bug_api.php Diff File

MantisBT: master 8e303d2c

2011-01-07 20:55:31

vboctor

Details Diff
Fix 0012667: Moving issues between projects doesn't update the category

If an issue with category GUI is moved from Project A to Project B (where both have the category defined as non-global), then the issue will show the category name in the view page as "[Project A] GUI" even though the issue now belongs to project B. Also if the user edits the issue, the first category is selected from the list since "[Project A] GUI" is not a valid entry.

The proposed fix is as follows:

1. If the category is global, then leave as is.
2. If the category has a match by name in the target project, then switch to that.
3. If the category doesn't have a match by name in the target project, then move a configured default global category (by default "General").
Affected Issues
0012667
mod - docbook/Admin_Guide/en-US/Configuration.xml Diff File
mod - bug_actiongroup.php Diff File
mod - core/bug_api.php Diff File
mod - config_defaults_inc.php Diff File

Issue History

Date Modified Username Field Change
2011-01-07 15:44 vboctor New Issue
2011-01-07 15:44 vboctor Status new => assigned
2011-01-07 15:44 vboctor Assigned To => vboctor
2011-01-07 16:08 vboctor Changeset attached => MantisBT master-1.2.x a25d69fc
2011-01-07 16:08 vboctor Resolution open => fixed
2011-01-07 16:08 vboctor Fixed in Version => 1.2.5
2011-01-07 16:10 atrol Relationship added related to 0005034
2011-01-07 16:15 atrol Relationship added related to 0010325
2011-01-07 16:17 atrol Relationship added related to 0007518
2011-01-07 16:18 atrol Relationship added related to 0006763
2011-01-07 16:20 atrol Relationship added related to 0004671
2011-01-07 17:49 vboctor Relationship replaced has duplicate 0004671
2011-01-07 17:57 vboctor Relationship added has duplicate 0009641
2011-01-08 22:28 vboctor Changeset attached => MantisBT master 8e303d2c
2011-01-08 22:31 vboctor Status assigned => resolved
2011-01-08 22:31 vboctor Fixed in Version 1.2.5 => 1.2.6
2011-01-08 22:32 vboctor Relationship replaced has duplicate 0007518
2011-01-09 19:29 dhx Fixed in Version 1.2.6 => 1.2.5
2011-04-03 16:57 atrol Relationship added has duplicate 0012896
2011-04-05 14:23 jreese Status resolved => closed
2011-09-16 11:03 dregad Relationship added related to 0013233