View Issue Details

IDProjectCategoryView StatusLast Update
0025184mantisbtcustom fieldspublic2019-05-21 22:42
Reportertruefriend-cz Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status confirmedResolutionopen 
Product Version2.19.0 
Target VersionFixed in Version 
Summary0025184: bug_report_page_fields by projects
Description

If adding bug_report_page_fields in Configuration report by project then it is not working.

If adding bug_report_page_fields in Configuration report for all projects (with same configuration) then working ok (but for all projects only).

TagsNo tags attached.

Relationships

has duplicate 0025211 closedatrol bug_report_page_fields by projects, part 2 
has duplicate 0025216 closedatrol bug_report_page_fields by projects, part 3 

Activities

atrol

atrol

2019-01-09 15:49

developer   ~0061179

truefriend-cz,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.19.0 at the moment).

Please provide detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
truefriend-cz

truefriend-cz

2019-01-10 00:13

reporter   ~0061181

Last edited: 2019-01-10 02:39

View 4 revisions

No. It is after clean install and added 4 projects and adding anonymous user. Source code not modified.

config_inc.php (lines begin "..." in file is not contained, replaced original for reporting):

<?php

...replaced database login info...

$g_default_timezone       = 'Europe/Prague';

$g_crypto_master_salt     = '...replaced blablabla...';

# --- anonymous login -----------
$g_allow_anonymous_login = ON;
$g_anonymous_account = 'anonymous';

# Optionally', 'if you want to use blank email addresses
$g_allow_blank_email = ON;

# My
$g_reauthentication_expiry = 60*60*3; // 3 hour expiration
truefriend-cz

truefriend-cz

2019-01-10 00:16

reporter   ~0061182

... big font lines config_inc.php have on begin lines hashtag symbol. I do not know why replace with big font.

dregad

dregad

2019-01-10 02:41

developer   ~0061185

... big font lines config_inc.php have on begin lines hashtag symbol. I do not know why replace with big font.

This is caused by Markdown processor; I edited your post to add so the config file is shown in a code block (using ```)

atrol

atrol

2019-01-10 17:30

developer   ~0061204

I am still not able to reproduce.

There is hardly any chance to help as long as you don't provide detailed step-by-step instructions.

truefriend-cz

truefriend-cz

2019-01-11 11:49

reporter   ~0061209

Last edited: 2019-01-11 12:23

View 17 revisions

I will not deal with it you. I"ve presented it on a forum and you"re still repeating the same thing as stupid. I not have more informations.

  1. step extracted ZIP file

  2. installing setup MySQL
    i presented as CLEAN INSTALL !!!, idiot !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  3. step add project (named Test A), add 2. project (named Test B), add 3, project (named Test C), add 4. project (named Test)

  4. step add config_inc.php said configuration

  5. step adding
    array (
    0 => 'attachments',
    1 => 'due_date',
    2 => 'handler',
    3 => 'os',
    4 => 'os_version',
    5 => 'priority',
    6 => 'product_build',
    7 => 'product_version',
    8 => 'severity',
    9 => 'target_version',
    10 => 'view_state',
    )
    by project.

  6. step
    I can not say exactly where it is in the Menu because I have already erased Mantis and ended up with his development and using and reporting bugs. I am currently looking for an alternative to not be able to meet with the kind of idiot Which rejects all requirements (before this tickets, maybe this too) and select asa "solved" for random reasons and can not do anything in practice and just mobbing I have met here.
    Please other users for calling police to artol and reported this conflict.

7+. step Thanks
8+. step Bye
9+. sorry for bad words, maybe if better developer then better user...

Thank you I could use Mantis from the earliest verisons when I was using RitLabs (about TheBAT). Your support and worker access through mobbing is worse than in the past, and again and again I have to stop developing and helping with your product. I hope you will soon get a personal out of order because I have not met such a blunder social access at the developer level for a long time.
Take a vacation or suicide. It"s your access is nasty. Have a nice day.

Solution access, ended words:
The approach I imagined is that after the problem has been reported, you will verify the problem and proceed accordingly. I tested the problem on several servers. And 3 times reinstalled. I tried to eliminate my own intervention as much as possible and tried to set up the required function as soon as possible after a clean installation. Just for that, I installed Mantis to test it and exclude that I had set something wrong somewhere. And some idiot is still harassing me here. I have had enough of this. You going to Shit even with Mantis product.

You DETAILED testing before public.

atrol

atrol

2019-01-11 12:57

developer   ~0061210

Last edited: 2019-01-11 13:01

View 2 revisions

@truefriend-cz

I invested time to support you in forum.
I invested time trying to reproduce your issue 0025185 but was not able to do so.
I invested also time in trying to reproduce this issue, but having different bug_report_page_fields in different projects works for me.
That’s why I am asking for detailed step by step instructions to reproduce.

rejects all requirements
"solved" for random reasons

I assume you are talking about 0025186
If so, you can reopen the issue and tell reasons why you don’t agree with what I told you in linked forum topic.
This is Open Source, this is Open Discussion

and again and again I have to stop developing and helping with your product

I have no idea what you are talking about

I am working for Mantis in my free time without getting paid for it..
You get Mantis for free, you get my support for free.
So there are good reasons for you to be happy instead of writing not acceptable comments like

kind of idiot
Take a vacation or suicide.
And some idiot is still harassing me here

atrol

atrol

2019-01-11 12:58

developer   ~0061211

Setting to resolved / unable to reproduce as I am not able to reproduce the issue and the reporter will not go on using Mantis.

truefriend-cz

truefriend-cz

2019-01-11 14:01

reporter   ~0061215

Last edited: 2019-01-11 16:09

View 12 revisions

I have of Mantis 135 tickets (before account than problem your server). From this tickets solved 134 with random "reasons".
The real solved problem has not been any than one.

If your policy is such, your product is a virus. Antivirus companyes thus describe the behavior of the virus.
"Real problems which are free of charge, but virus writers refuse to solve the problems free of charge."
This behavior is criminal.

I tested on Windows.

  1. server: Project XAMP - https://www.apachefriends.org/index.html
  2. server: Project USBWebserver V8 (php 5.6, php 7.1, portable server) - https://usbwebserver.yura.mk.ua
  3. server: Project UniServerZ (portable server, php 5.6, php 7.1) - http://www.uniformserver.com/

On project UniServerZ (3. server) get next this bug: https://mantisbt.org/bugs/view.php?id=22752 (unresolved from first version).

All servers is CLEAN (base) install or running (portable versions with default configurations), with default database from Mantis wizard install. User for connect to database is with full rights only (no root, but other).

For testing I recomending USBWebserver.

I will be back from backup: On Linux server hosting provider:
http://sg4-cz.tk/bugs/
login: administrator
password: Pass555

Settings Array applyed on project "Test" (in adm_config_report.php)

config_inc.php:

# --- anonymous login -----------
$g_allow_anonymous_login = ON;
$g_anonymous_account = 'anonymous';

# My
$g_reauthentication_expiry = 60*60*3; // 3 hour expiration

no MODs files.

truefriend-cz

truefriend-cz

2019-01-12 05:03

reporter   ~0061216

Last edited: 2019-01-12 05:34

View 4 revisions

Next info from testing:
No same fields for anonymous and registered users on bug_report_page.php.
In the settings adm_config_report.php is for all users by project same.

If visit bug_report_page.php as anonymous then this user used global arrays fields. But in adm_config_report.php is defined individual array settings by project and this your script ignored. Why?

dregad

dregad

2019-01-12 13:27

developer   ~0061217

@truefriend-cz considering how you responded to @atrol in your earlier post, do you really expect that someone is going to be willing to help you? �

atrol

atrol

2019-01-13 05:51

developer   ~0061220

@truefriend-cz as everybody can see, this even works on your own installation.



ReportTest.png (88,895 bytes)
ReportTest.png (88,895 bytes)
ReportTest2.png (89,150 bytes)
ReportTest2.png (89,150 bytes)
atrol

atrol

2019-01-14 03:55

developer   ~0061224

It was worth to ignore all this unacceptable bashing and ask again and again for detailed information to reproduce the issue.
Finally I am able to reproduce the issue after reading the latest bashing and information in forum.

Deeper investigation is needed, what I can tell until now:

We are talking about an issue which appears just when using anonymous access in way which is not recommended
https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.misc

It is suggested that the access level for this account be set to VIEWER or some other read only level. 

There is also a dependency to the way you access pages.
It works as expected when using the "Anonymous Login" link on login page before accessing pages, but does deliver unexpected results when directly accessing pages without taking the step to login.

Furthermore the behavior depends on browser cookies that might exist or not, depending on a previous login.

I will ask another developer who is more involved in this part of the code than me, if he can have a look at the issue.

truefriend-cz

truefriend-cz

2019-01-15 07:11

reporter   ~0061241

Bug is if:
If you open bug_report_page.php any browser where before is cleaned histroy, cache, etc. then showed items as default.

All right if:
If you open bug_report_page.php any browser where before login as administrator and logout and show page by project as anonymous show page items all right, no bug.

After clean histroy and cache and reload page show bad (bug is) items.

truefriend-cz

truefriend-cz

2019-05-21 22:42

reporter   ~0062110

Do you can planing target version, please?

Issue History

Date Modified Username Field Change
2019-01-09 12:02 truefriend-cz New Issue
2019-01-09 15:49 atrol Status new => feedback
2019-01-09 15:49 atrol Note Added: 0061179
2019-01-10 00:13 truefriend-cz Note Added: 0061181
2019-01-10 00:13 truefriend-cz Status feedback => new
2019-01-10 00:16 truefriend-cz Note Added: 0061182
2019-01-10 00:19 truefriend-cz Note Edited: 0061181 View Revisions
2019-01-10 00:19 truefriend-cz Note Edited: 0061181 View Revisions
2019-01-10 02:39 dregad Note Edited: 0061181 View Revisions
2019-01-10 02:41 dregad Note Added: 0061185
2019-01-10 17:30 atrol Status new => feedback
2019-01-10 17:30 atrol Note Added: 0061204
2019-01-11 11:49 truefriend-cz Note Added: 0061209
2019-01-11 11:49 truefriend-cz Status feedback => new
2019-01-11 11:49 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 11:50 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 11:52 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 11:56 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 11:57 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:00 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:01 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:02 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:03 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:10 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:11 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:13 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:20 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:21 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:23 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:23 truefriend-cz Note Edited: 0061209 View Revisions
2019-01-11 12:57 atrol Note Added: 0061210
2019-01-11 12:58 atrol Assigned To => atrol
2019-01-11 12:58 atrol Status new => resolved
2019-01-11 12:58 atrol Resolution open => unable to reproduce
2019-01-11 12:58 atrol Note Added: 0061211
2019-01-11 13:01 atrol Note Edited: 0061210 View Revisions
2019-01-11 14:01 truefriend-cz Note Added: 0061215
2019-01-11 14:02 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 15:40 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 15:45 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 15:46 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:01 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:02 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:02 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:03 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:03 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:06 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-11 16:09 truefriend-cz Note Edited: 0061215 View Revisions
2019-01-12 05:03 truefriend-cz Note Added: 0061216
2019-01-12 05:13 truefriend-cz Note Edited: 0061216 View Revisions
2019-01-12 05:14 truefriend-cz Note Edited: 0061216 View Revisions
2019-01-12 05:34 truefriend-cz Note Edited: 0061216 View Revisions
2019-01-12 13:27 dregad Note Added: 0061217
2019-01-13 05:51 atrol File Added: ReportTest.png
2019-01-13 05:51 atrol File Added: ReportTest2.png
2019-01-13 05:51 atrol Note Added: 0061220
2019-01-13 05:56 atrol Relationship added has duplicate 0025211
2019-01-13 10:39 atrol Relationship added has duplicate 0025216
2019-01-14 03:55 atrol Priority high => normal
2019-01-14 03:55 atrol Status resolved => confirmed
2019-01-14 03:55 atrol Resolution unable to reproduce => open
2019-01-14 03:55 atrol Note Added: 0061224
2019-01-14 03:57 atrol Assigned To atrol =>
2019-01-15 07:11 truefriend-cz Note Added: 0061241
2019-05-21 22:42 truefriend-cz Note Added: 0062110