End of PHP 5 support

Since MantisBT 2.0.0, we officially support PHP 5.5.9 and later, aligned with Ubuntu 14.04 LTS “Trusty Tahr” release.

PHP 5.5 has reached end-of-life on July 21st, 2016 and PHP 5.6 support ended on December 31st, 2018 so the time has finally come for us to turn the page and leave 5.x behind, as maintaining compatibility is becoming increasingly difficult with more and more libraries and tools dropping support for it.

Consequently, the upcoming MantisBT 2.25.0 release will be the last one supporting PHP 5.

Starting with MantisBT 2.26.0, the minimum PHP version will be 7.0. This follows our strategy to align our requirements with Ubuntu LTS releases; as of this writing, the oldest one is 16.04 Xenial Xerus, which comes bundled with PHP 7.0.

Note that while PHP 7.0 is also end-of-life since January 10th, 2019, the Ubuntu team is committed to maintaining it for the lifetime of the 16.04 LTS release. Nevertheless, the MantisBT team recommends to run a fully supported PHP version, i.e. 7.3 or later.

Finally, please be advised that we will increase the minimum PHP version again in just a few months, as 16.04 LTS support ends in April 2021. The following LTS release, 18.04 Bionic Beaver, comes bundled with PHP 7.2.

EDIT (October 2023): Real life got in the way of things, and MantisBT 2.26.0 could not be released in 2021 as initially planned… It did not really make sense to set our minimum supported PHP version to 7.0 anymore, so we went straight to 7.2 instead.